Skip to content
Laskyr

Plugins · rootblox · data as of 2026-11-04

Is Rootblox safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.0.8)

As of 2026-11-04. 2 issues are on record for older versions; version 1.0.8 or newer fixes all of them that state a fix.

Latest version
1.0.8
Last updated
2026-10-19
Active installs
90+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.3+

Create headers and footers with multiple block patterns. Easily customize layout and style for a polished look! — by CozyThemes

What to do

  1. Update to the latest version (1.0.8). Anything older than 1.0.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get rootblox --field=version shows what you run; wp plugin update rootblox updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.8 CVE-2026-112832 · published 2026-10-22

File inclusion in Rootblox (1.0.6 and older)

Affected
1.0.6 and older
Fixed in
1.0.7
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in CozyThemes Rootblox rootblox allows PHP Local File Inclusion.This issue affects Rootblox: from n/a through 1.0.6.

NVD CVE-2026-112832Patchstack advisory

medium 6.5 CVE-2026-111843 · published 2026-10-20

Stored cross-site scripting (XSS) in Rootblox (1.0.7 and older)

Affected
1.0.7 and older
Fixed in
1.0.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CozyThemes Rootblox rootblox allows Stored XSS.This issue affects Rootblox: from n/a through 1.0.7.

NVD CVE-2026-111843Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Rootblox vulnerability status badge
<a href="https://laskyr.com/plugins/rootblox"><img src="https://laskyr.com/plugins/rootblox/badge.svg" alt="Rootblox vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit