Plugins · romancart-ecommerce · data as of 2026-11-04
Is RomanCart Ecommerce safe? Known vulnerabilities and latest version
- Latest version
- 2.0.9
- Last updated
- 2026-10-06
- Active installs
- 10+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
Add Buy Buttons, Widgets or an entire Storefront to your pages and sell products, tickets and digital downloads in minutes. — by romancartsupport
What to do
- Update to the latest version (2.0.9). Anything older than 2.0.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get romancart-ecommerce --field=version shows what you run; wp plugin update romancart-ecommerce updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-8880 · published 2026-06-09
Stored cross-site scripting (XSS) in RomanCart Ecommerce (2.0.8 and older)
- Affected
- 2.0.8 and older
- Fixed in
- 2.0.9 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The RomanCart Ecommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'blclass' attribute (and other attributes) of the romancart_button shortcode in versions up to, and including, 2.0.8. This is due to insufficient input sanitization and output escaping on user supplied attributes within the romancart_button_shortcode() function. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recent activity
- 2026-10-06 — latest release on wordpress.org (2.0.9).
- 2026-06-09 — Stored cross-site scripting (XSS) disclosed (CVE-2026-8880), fixed in 2.0.9.
Get an email when RomanCart Ecommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for RomanCart Ecommerce (romancart-ecommerce) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/romancart-ecommerce (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/romancart-ecommerce"><img src="https://laskyr.com/plugins/romancart-ecommerce/badge.svg" alt="RomanCart Ecommerce vulnerability status"></a>