Skip to content
Laskyr

Plugins · rocket-lazy-load · data as of 2026-11-04

Is LazyLoad Plugin safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.4.1)

As of 2026-11-04. 2 issues are on record for older versions; version 2.4.1 or newer fixes all of them that state a fix.

Latest version
2.4.1
Last updated
2026-10-06
Active installs
100,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

The best free lazy load plugin for WordPress. Lazy load images, videos, and iframes to improve performance and Core Web Vitals scores. — by WP Media

What to do

  1. Update to the latest version (2.4.1). Anything older than 2.4.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get rocket-lazy-load --field=version shows what you run; wp plugin update rocket-lazy-load updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-100196 · published 2026-10-10

Stored cross-site scripting (XSS) in LazyLoad Plugin (2.4.0 and older)

Affected
2.4.0 and older
Fixed in
2.4.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The LazyLoad Plugin – Lazy Load Images, Videos, and Iframes plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment_content (rendered inline into the page HTML)' parameter in all versions up to, and including, 2.4.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. WordPress core's wp_kses_data allow-list does not strip the crafted payload on save because it uses only permitted tags and attributes; the event handler is concealed inside a broken attribute region and is only promoted to a real DOM attribute by the plugin's render-time str_replace transformation. Additionally, a site administrator must approve the crafted comment before the payload is served to other visitors.

NVD CVE-2026-100196Wordfence advisoryCode change (fix)wordpress.orgPlugin source

medium 6.5 CVE-2026-105884 · published 2026-10-07

Stored cross-site scripting (XSS) in LazyLoad Plugin (2.4.0 and older)

Affected
2.4.0 and older
Fixed in
2.4.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP Media Rocket Lazy Load rocket-lazy-load allows Stored XSS.This issue affects Rocket Lazy Load: from n/a through 2.4.0.

NVD CVE-2026-105884Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
LazyLoad Plugin vulnerability status badge
<a href="https://laskyr.com/plugins/rocket-lazy-load"><img src="https://laskyr.com/plugins/rocket-lazy-load/badge.svg" alt="LazyLoad Plugin vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit