Plugins · robokassa · data as of 2026-11-04
Is Robokassa payment gateway for Woocommerce safe? Known vulnerabilities and latest version
- Latest version
- 1.9.1
- Last updated
- 2026-10-28
- Active installs
- 3,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.4+
Позволяет использовать интерфейс (платежный шлюз) для оплаты через Робокассу в WooCommerce. Поддерживает интеграцию чеков (закон 54-ФЗ) — by robokassa
What to do
- Update to the latest version (1.9.1). Anything older than 1.9.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get robokassa --field=version shows what you run; wp plugin update robokassa updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
low 3.7 CVE-2026-91017 · published 2026-09-17
Security issue in Robokassa payment gateway for Woocommerce (older than 1.8.9)
- Affected
- older than 1.8.9
- Fixed in
- 1.8.9
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by WPScan
Details from the advisory
The Robokassa payment gateway for Woocommerce WordPress plugin before 1.8.9 does not verify the authenticity of incoming payment notifications when its non-default deferred-payment feature is enabled, allowing unauthenticated attackers to forge a notification and mark arbitrary WooCommerce orders as paid or on-hold without payment or a valid signature.
medium 6.5 CVE-2026-78536 · published 2026-09-10
Missing authorization check in Robokassa payment gateway for Woocommerce (1.8.9 and older)
- Affected
- 1.8.9 and older
- Fixed in
- 1.9.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Broken Access Control in Robokassa payment gateway for Woocommerce <= 1.8.9 versions.
high 7.1 CVE-2025-49958 · published 2025-10-22
Reflected cross-site scripting (XSS) in Robokassa payment gateway for Woocommerce (1.8.6 and older)
- Affected
- 1.8.6 and older
- Fixed in
- 1.8.8 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in robokassa Robokassa payment gateway for Woocommerce robokassa allows Reflected XSS.This issue affects Robokassa payment gateway for Woocommerce: from n/a through <= 1.8.6.
high 7.1 CVE-2024-47395 · published 2024-10-05
Reflected cross-site scripting (XSS) in Robokassa payment gateway for Woocommerce (1.6.1 and older)
- Affected
- 1.6.1 and older
- Fixed in
- 1.6.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in robokassa Robokassa payment gateway for Woocommerce robokassa allows Reflected XSS.This issue affects Robokassa payment gateway for Woocommerce: from n/a through <= 1.6.1.
Recent activity
- 2026-10-28 — latest release on wordpress.org (1.9.1).
- 2026-09-17 — Security issue disclosed (CVE-2026-91017), fixed in 1.8.9.
- 2026-09-10 — Missing authorization check disclosed (CVE-2026-78536), fixed in 1.9.0.
- 2025-10-22 — Reflected cross-site scripting (XSS) disclosed (CVE-2025-49958), fixed in 1.8.8.
Get an email when Robokassa payment gateway for Woocommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Robokassa payment gateway for Woocommerce (robokassa) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/robokassa (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/robokassa"><img src="https://laskyr.com/plugins/robokassa/badge.svg" alt="Robokassa payment gateway for Woocommerce vulnerability status"></a>