Skip to content
Laskyr

Plugins · robin-image-optimizer · data as of 2026-11-04

Is Robin Image Optimizer safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.1.0)

As of 2026-11-04. 4 issues are on record for older versions; version 2.0.8 or newer fixes all of them that state a fix.

Latest version
2.1.0
Last updated
2026-11-03
Active installs
100,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Unlimited automatic image optimization for WordPress. Compress images, convert to WebP, and improve site speed without losing image quality. — by Themeisle

What to do

  1. Update to the latest version (2.1.0). Anything older than 2.0.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get robin-image-optimizer --field=version shows what you run; wp plugin update robin-image-optimizer updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-89190 · published 2026-09-30

Missing authorization check in Robin Image Optimizer (older than 2.0.8)

Affected
older than 2.0.8
Fixed in
2.0.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Robin Image Optimizer WordPress plugin before 2.0.8 does not check the user's capabilities before dispatching one of its bundled admin framework's request handlers, allowing users with a subscriber-level account to render admin-only Robin Image Optimizer WordPress plugin before 2.0.8 pages and disclose the Robin Image Optimizer WordPress plugin before 2.0.8's stored settings.

NVD CVE-2026-89190WPScan advisory

high 7.5 CVE-2026-89193 · published 2026-09-30

Cross-site scripting (XSS) in Robin Image Optimizer (2.0.0 up to (not including) 2.0.8)

Affected
2.0.0 up to (not including) 2.0.8
Fixed in
2.0.8
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Robin Image Optimizer WordPress plugin before 2.0.8 does not escape values that its bundled HTML parser re-emits into element attributes when a non-default image delivery mode is enabled, allowing unauthenticated users to submit content that is stored and later executed as Cross-Site Scripting in the browser of any user viewing an affected page, including administrators.

NVD CVE-2026-89193WPScan advisory

medium 6.4 CVE-2026-1319 · published 2026-02-05

Stored cross-site scripting (XSS) in Robin Image Optimizer (2.0.2 and older)

Affected
2.0.2 and older
Fixed in
2.0.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Robin Image Optimizer – Unlimited Image Optimization & WebP Converter plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'Alternative Text' field of a Media Library image in all versions up to, and including, 2.0.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-1319Wordfence advisoryCode change (fix)

medium 6.5 CVE-2024-43122 · published 2024-11-01

Missing authorization check in Robin Image Optimizer (1.6.9 and older)

Affected
1.6.9 and older
Fixed in
1.7.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Creative Motion Robin image optimizer allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Robin image optimizer: from n/a through 1.6.9.

NVD CVE-2024-43122Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Robin Image Optimizer vulnerability status badge
<a href="https://laskyr.com/plugins/robin-image-optimizer"><img src="https://laskyr.com/plugins/robin-image-optimizer/badge.svg" alt="Robin Image Optimizer vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit