Skip to content
Laskyr

Plugins · revisionary · data as of 2026-11-04

Is PublishPress Revisions safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.3.2)

As of 2026-11-04. 4 issues are on record for older versions; version 3.7.24 or newer fixes all of them that state a fix.

Latest version
4.3.2
Last updated
2026-11-03
Active installs
10,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.2+

Control how published content is updated. Users submit revisions and duplicate posts. Editors can approve, reject or schedule those revisions. — by PublishPress

What to do

  1. Update to the latest version (4.3.2). Anything older than 3.7.24 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get revisionary --field=version shows what you run; wp plugin update revisionary updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.3 CVE-2026-32539 · published 2026-03-25

SQL injection in PublishPress Revisions (3.7.23 and older)

Affected
3.7.23 and older
Fixed in
3.7.24
Access needed (per CVSS)
No login needed
Range from
advisory text · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in PublishPress PublishPress Revisions revisionary allows Blind SQL Injection.This issue affects PublishPress Revisions: from n/a through <= 3.7.23.

NVD CVE-2026-32539Patchstack advisory

medium 5.4 CVE-2026-25322 · published 2026-02-19

Cross-site request forgery (CSRF) in PublishPress Revisions (3.7.22 and older)

Affected
3.7.22 and older
Fixed in
3.7.23
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in PublishPress PublishPress Revisions revisionary allows Cross Site Request Forgery.This issue affects PublishPress Revisions: from n/a through <= 3.7.22.

NVD CVE-2026-25322Patchstack advisory

medium 4.3 CVE-2024-11154 · published 2024-11-20

Information disclosure in PublishPress Revisions (3.5.15 and older)

Affected
3.5.15 and older
Fixed in
3.5.16 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The PublishPress Revisions: Duplicate Posts, Submit, Approve and Schedule Content Changes plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.5.15 via the 'actAjaxRevisionDiffs' function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to extract sensitive data including revisions of posts and pages.

NVD CVE-2024-11154Wordfence advisoryCode change (fix)github.comPlugin source

medium 6.1 CVE-2024-9436 · published 2024-10-11

Reflected cross-site scripting (XSS) in PublishPress Revisions (3.5.14 and older)

Affected
3.5.14 and older
Fixed in
3.5.15 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The PublishPress Revisions: Duplicate Posts, Submit, Approve and Schedule Content Changes plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 3.5.14. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2024-9436Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
PublishPress Revisions vulnerability status badge
<a href="https://laskyr.com/plugins/revisionary"><img src="https://laskyr.com/plugins/revisionary/badge.svg" alt="PublishPress Revisions vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit