Skip to content
Laskyr

Plugins · retainful · data as of 2026-11-04

Is Email Marketing for WordPress and WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.0.11)

As of 2026-11-04. 1 issue is on record for older versions; version 1.0.11 or newer fixes all of them that state a fix.

Latest version
1.0.11
Last updated
2026-10-05
Active installs
600+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Email marketing, newsletters for WordPress and WooCommerce. Send newsletters and campaigns, recover abandoned carts, signup forms, and more — by retainful

What to do

  1. Update to the latest version (1.0.11). Anything older than 1.0.11 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get retainful --field=version shows what you run; wp plugin update retainful updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-97396 · published 2026-10-10

Stored cross-site scripting (XSS) in Email Marketing for WordPress and WooCommerce (1.0.10 and older)

Affected
1.0.10 and older
Fixed in
1.0.11 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Email Marketing for WordPress and WooCommerce – Retainful plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'data' parameter in all versions up to, and including, 1.0.10 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-97396Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Email Marketing for WordPress and WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/retainful"><img src="https://laskyr.com/plugins/retainful/badge.svg" alt="Email Marketing for WordPress and WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit