Skip to content
Laskyr

Plugins · restricted-site-access · data as of 2026-11-04

Is Restricted Site Access safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (7.6.4)

As of 2026-11-04. 3 issues are on record for older versions; version 7.6.3 or newer fixes all of them that state a fix.

Latest version
7.6.4
Last updated
2026-10-14
Active installs
10,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Limit access to visitors who are logged in or allowed by IP addresses. Includes many options for handling blocked visitors. — by 10up

What to do

  1. Update to the latest version (7.6.4). Anything older than 7.6.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get restricted-site-access --field=version shows what you run; wp plugin update restricted-site-access updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-110227 · published 2026-10-14

Missing authorization check in Restricted Site Access (7.6.2 and older)

Affected
7.6.2 and older
Fixed in
7.6.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in 10up Restricted Site Access restricted-site-access allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Restricted Site Access: from n/a through 7.6.2.

NVD CVE-2026-110227Patchstack advisory

medium 5.3 CVE-2023-48753 · published 2024-06-04

Authentication bypass in Restricted Site Access (7.4.1 and older)

Affected
7.4.1 and older
Fixed in
7.5.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Authentication Bypass by Spoofing vulnerability in 10up Restricted Site Access allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Restricted Site Access: from n/a through 7.4.1.

NVD CVE-2023-48753Patchstack advisory

medium 5.3 CVE-2022-1613 · published 2022-09-26

Missing authorization check in Restricted Site Access (older than 7.3.2)

Affected
older than 7.3.2
Fixed in
7.3.2
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

The Restricted Site Access WordPress plugin before 7.3.2 prioritizes getting a visitor's IP from certain HTTP headers over PHP's REMOTE_ADDR, which makes it possible to bypass IP-based limitations in certain situations.

NVD CVE-2022-1613WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Restricted Site Access vulnerability status badge
<a href="https://laskyr.com/plugins/restricted-site-access"><img src="https://laskyr.com/plugins/restricted-site-access/badge.svg" alt="Restricted Site Access vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit