Plugins · restrict-user-access · data as of 2026-11-04
Is Restrict User Access safe? Known vulnerabilities and latest version
- Latest version
- 2.8.3
- Last updated
- 2026-10-23
- Active installs
- 10,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Create Access Levels and restrict any post, page, category, etc. Supports bbPress, BuddyPress, WooCommerce, WPML, and more. — by Joachim Jensen
What to do
- Update to the latest version (2.8.3). Anything older than 2.8.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get restrict-user-access --field=version shows what you run; wp plugin update restrict-user-access updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-62040 · published 2026-10-09
Missing authorization check in Restrict User Access (2.8.1 and older)
- Affected
- 2.8.1 and older
- Fixed in
- 2.8.2
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in DEV Institute Restrict User Access – Membership Plugin with Force restrict-user-access allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Restrict User Access – Membership Plugin with Force: from n/a through 2.8.1.
medium 5.3 CVE-2026-78153 · published 2026-09-02
Missing authorization check in Restrict User Access (2.6 up to (not including) 2.8.1)
- Affected
- 2.6 up to (not including) 2.8.1
- Fixed in
- 2.8.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by WPScan
Details from the advisory
The Restrict User Access WordPress plugin before 2.8.1 does not normalise the REST API route before checking it against the routes its content protection covers, allowing unauthenticated users to bypass that protection and read restricted content and enumerate users.
medium 6.1 CVE-2024-29138 · published 2024-03-19
Cross-site scripting (XSS) in Restrict User Access (2.5 and older)
- Affected
- 2.5 and older
- Fixed in
- 2.6
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Joachim Jensen Restrict User Access – Membership Plugin with Force restrict-user-access.This issue affects Restrict User Access – Membership Plugin with Force: from n/a through <= 2.5.
medium 5.3 CVE-2024-0687 · published 2024-03-13
Information disclosure in Restrict User Access (2.5 and older)
- Affected
- 2.5 and older
- Fixed in
- 2.6 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Restrict User Access – Ultimate Membership & Content Protection plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 2.5 via API. This makes it possible for unauthenticated attackers to obtain the contents of posts and pages via API.
Recent activity
- 2026-10-23 — latest release on wordpress.org (2.8.3).
- 2026-10-09 — Missing authorization check disclosed (CVE-2026-62040), fixed in 2.8.2.
- 2026-09-02 — Missing authorization check disclosed (CVE-2026-78153), fixed in 2.8.1.
- 2024-03-19 — Cross-site scripting (XSS) disclosed (CVE-2024-29138), fixed in 2.6.
Get an email when Restrict User Access has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Restrict User Access (restrict-user-access) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (2) · Cross-site scripting (XSS) (1) · Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/restrict-user-access (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/restrict-user-access"><img src="https://laskyr.com/plugins/restrict-user-access/badge.svg" alt="Restrict User Access vulnerability status"></a>