Skip to content
Laskyr

Plugins · responsive-block-control · data as of 2026-11-04

Is Responsive Block Control safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.3.2)

As of 2026-11-04. 1 issue is on record for older versions; version 1.3.1 or newer fixes all of them that state a fix.

Latest version
1.3.2
Last updated
2026-02-21
Active installs
1,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.4+

Responsive Block Control adds responsive toggles to a "Visibility" panel of the block editor, to show or hide blocks according to screen width. — by landwire

What to do

  1. Update to the latest version (1.3.2). Anything older than 1.3.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get responsive-block-control --field=version shows what you run; wp plugin update responsive-block-control updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-62135 · published 2025-12-31

Cross-site scripting (XSS) in Responsive Block Control (1.3.0 and older)

Affected
1.3.0 and older
Fixed in
1.3.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in landwire Responsive Block Control responsive-block-control allows DOM-Based XSS.This issue affects Responsive Block Control: from n/a through <= 1.3.0.

NVD CVE-2025-62135Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Responsive Block Control vulnerability status badge
<a href="https://laskyr.com/plugins/responsive-block-control"><img src="https://laskyr.com/plugins/responsive-block-control/badge.svg" alt="Responsive Block Control vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit