Plugins · responsive-add-ons · data as of 2026-11-04
Is Responsive Starter Templates safe? Known vulnerabilities and latest version
- Latest version
- 3.5.5
- Last updated
- 2026-10-21
- Active installs
- 10,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11 · PHP 5.6+
Import free and pro Gutenberg and Elementor Templates for the Responsive WordPress theme. — by CyberChimps
What to do
- Update to the latest version (3.5.5). Anything older than 3.5.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get responsive-add-ons --field=version shows what you run; wp plugin update responsive-add-ons updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-15795 · published 2026-10-03
Stored cross-site scripting (XSS) in Responsive Starter Templates (3.5.3 and older)
- Affected
- 3.5.3 and older
- Fixed in
- 3.5.4 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Responsive Plus – Elementor Templates & Starter Sites plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Shortcode Attributes in all versions up to, and including, 3.5.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-15795Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2025-49856 · published 2025-06-17
Cross-site request forgery (CSRF) in Responsive Starter Templates (3.2.2 and older)
- Affected
- 3.2.2 and older
- Fixed in
- 3.2.3
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in CyberChimps Responsive Plus responsive-add-ons allows Cross Site Request Forgery.This issue affects Responsive Plus: from n/a through <= 3.2.2.
medium 5.4 CVE-2025-48335 · published 2025-06-06
Missing authorization check in Responsive Starter Templates (3.2.0 and older)
- Affected
- 3.2.0 and older
- Fixed in
- 3.2.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in CyberChimps Responsive Plus responsive-add-ons allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Responsive Plus: from n/a through <= 3.2.0.
medium 5.3 CVE-2025-47486 · published 2025-05-07
Missing authorization check in Responsive Starter Templates (3.1.9 and older)
- Affected
- 3.1.9 and older
- Fixed in
- 3.2.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in CyberChimps Responsive Plus responsive-add-ons allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Responsive Plus: from n/a through <= 3.1.9.
medium 5.4 CVE-2024-13834 · published 2025-02-15
Server-side request forgery (SSRF) in Responsive Starter Templates (3.1.4 and older)
- Affected
- 3.1.4 and older
- Fixed in
- 3.1.5 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Responsive Plus – Starter Templates, Advanced Features and Customizer Settings for Responsive Theme plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 3.1.4 via the 'remote_request' function. This makes it possible for authenticated attackers, with contributor-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.
medium 5.4 CVE-2024-5222 · published 2024-06-05
Stored cross-site scripting (XSS) in Responsive Starter Templates (3.0.5 and older)
- Affected
- 3.0.5 and older
- Fixed in
- 3.0.6 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Responsive Addons – Starter Templates, Advanced Features and Customizer Settings for Responsive Theme. plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's file uploader in all versions up to, and including, 3.0.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2024-5222Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-10-21 — latest release on wordpress.org (3.5.5).
- 2026-10-03 — Stored cross-site scripting (XSS) disclosed (CVE-2026-15795), fixed in 3.5.4.
- 2025-06-17 — Cross-site request forgery (CSRF) disclosed (CVE-2025-49856), fixed in 3.2.3.
- 2025-06-06 — Missing authorization check disclosed (CVE-2025-48335), fixed in 3.2.1.
Get an email when Responsive Starter Templates has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Responsive Starter Templates (responsive-add-ons) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by CyberChimps (3 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · Missing authorization (2) · Cross-site request forgery (CSRF) (1) · Server-side request forgery (SSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/responsive-add-ons (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/responsive-add-ons"><img src="https://laskyr.com/plugins/responsive-add-ons/badge.svg" alt="Responsive Starter Templates vulnerability status"></a>