Skip to content
Laskyr

Plugins · repeater-for-gravity-forms · data as of 2026-11-04

Is Repeater Fields for Gravity Forms safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.2.4)

As of 2026-11-04. 1 issue is on record for older versions; version 3.1.0 or newer fixes all of them that state a fix.

Latest version
3.2.4
Last updated
2026-10-14
Active installs
1,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.2+

The Repeater Fields for Gravity Forms allow you to create one or more sets of fields that can be repeated. — by add-ons.org

What to do

  1. Update to the latest version (3.2.4). Anything older than 3.1.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get repeater-for-gravity-forms --field=version shows what you run; wp plugin update repeater-for-gravity-forms updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-84293 · published 2026-09-09

Stored cross-site scripting (XSS) in Repeater Fields for Gravity Forms (3.0.4 and older)

Affected
3.0.4 and older
Fixed in
3.1.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Repeater Fields for Gravity Forms plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Repeated Multi-Input Sub-Field Values in all versions up to, and including, 3.0.4 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability only affects multi-input sub-field types within a repeater (such as Name, Address, and Checkbox fields), as scalar single-input field values are escaped with esc_html() at the output stage in version 3.0.4.

NVD CVE-2026-84293Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Repeater Fields for Gravity Forms vulnerability status badge
<a href="https://laskyr.com/plugins/repeater-for-gravity-forms"><img src="https://laskyr.com/plugins/repeater-for-gravity-forms/badge.svg" alt="Repeater Fields for Gravity Forms vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit