Skip to content
Laskyr

Plugins · rentsyst · data as of 2026-11-04

Is RentSyst safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.1.11)

As of 2026-11-04. 3 issues are on record for older versions; version 2.1.6 or newer fixes all of them that state a fix.

Latest version
2.1.11
Last updated
2026-11-03
Active installs
100+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

RentSyst - this plugin is suitable for the car rental business, which is designed to organize, optimize and simplify the work of the company. — by dimafreund

What to do

  1. Update to the latest version (2.1.11). Anything older than 2.1.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get rentsyst --field=version shows what you run; wp plugin update rentsyst updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-84835 · published 2026-09-02

Missing authorization check in RentSyst (2.1.5 and older)

Affected
2.1.5 and older
Fixed in
2.1.6 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in DimaFreund Rentsyst rentsyst allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Rentsyst: from n/a through 2.1.5.

NVD CVE-2026-84835Patchstack advisory

high 7.1 CVE-2025-48152 · published 2025-08-20

Reflected cross-site scripting (XSS) in RentSyst (2.0.100 and older)

Affected
2.0.100 and older
Fixed in
2.0.101
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in dimafreund Rentsyst rentsyst allows Reflected XSS.This issue affects Rentsyst: from n/a through <= 2.0.100.

NVD CVE-2025-48152Patchstack advisory

high 7.1 CVE-2025-32501 · published 2025-04-09

Cross-site request forgery (CSRF) in RentSyst (2.0.92 and older)

Affected
2.0.92 and older
Fixed in
2.0.93
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in dimafreund Rentsyst rentsyst allows Stored XSS.This issue affects Rentsyst: from n/a through <= 2.0.92.

NVD CVE-2025-32501Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
RentSyst vulnerability status badge
<a href="https://laskyr.com/plugins/rentsyst"><img src="https://laskyr.com/plugins/rentsyst/badge.svg" alt="RentSyst vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit