Skip to content
Laskyr

Plugins · related-posts-for-wp · data as of 2026-11-04

Is Related Posts for WordPress safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.0.1)

As of 2026-11-04. 5 issues are on record for older versions; version 3.0.1 or newer fixes all of them that state a fix.

Latest version
3.0.1
Last updated
2026-10-20
Active installs
10,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.0+

The best WordPress plugin for related posts. Simple, flexible, powerful algorithm, and built-in caching. Fully set up with only 1 click! — by Barry Kooij

What to do

  1. Update to the latest version (3.0.1). Anything older than 3.0.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get related-posts-for-wp --field=version shows what you run; wp plugin update related-posts-for-wp updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-109979 · published 2026-10-28

Information disclosure in Related Posts for WordPress (3.0.0 and older)

Affected
3.0.0 and older
Fixed in
3.0.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Related Posts for WordPress plugin for WordPress is vulnerable to Sensitive Information Exposure in versions up to, and including, 3.0.0 via the 'rp4wp_create_link' parameter of the hidden 'rp4wp_link_related' admin page. The handle_create_link() handler verifies the nonce and that the current user can edit the parent post, but never checks that the attacker-supplied child post ID is one the user is allowed to read; LinkRepository::insert() stores the arbitrary child ID without validation, and ManageLinks::render() later calls LinkRepository::get_children() in its no-extra-args fast path, which falls through to array_map('get_post', $child_ids) — bypassing read_private_posts/read_post capability checks — and then echoes esc_html($child->post_title) in the parent's editor meta box. This makes it possible for authenticated attackers, with Contributor-level access and above, to read the titles of arbitrary non-public posts (drafts, pending, private, future, trashed) authored by higher-privileged users by linking those post IDs to a draft they own and then reading the resulting meta box.

NVD CVE-2026-109979Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2026-109980 · published 2026-10-28

Information disclosure in Related Posts for WordPress (3.0.0 and older)

Affected
3.0.0 and older
Fixed in
3.0.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Related Posts for WordPress plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.0.0 via the 'rp4wp_view' parameter. This makes it possible for authenticated attackers, with contributor-level access and above, to extract the titles and publication dates of all private posts site-wide, normally restricted to Editor-level users and above. The page's existing authorization check only verifies edit_posts and edit_post on a parent post the attacker owns, both of which any Contributor satisfies, leaving no effective gate against reading other authors' private posts.

NVD CVE-2026-109980Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2024-0592 · published 2024-03-13

Cross-site request forgery (CSRF) in Related Posts for WordPress (2.2.1 and older)

Affected
2.2.1 and older
Fixed in
2.2.2 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Related Posts for WordPress plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.2.1. This is due to missing or incorrect nonce validation on the handle_create_link() function. This makes it possible for unauthenticated attackers to add related posts to other posts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. This ultimately makes it possible for attackers to view draft and password protected posts.

NVD CVE-2024-0592Wordfence advisoryCode change (fix)Plugin source

medium 4.8 CVE-2021-24482 · published 2021-07-19

Stored cross-site scripting (XSS) in Related Posts for WordPress (2.0.4 to 2.0.4)

Affected
2.0.4 to 2.0.4
Fixed in
2.0.5 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Related Posts for WordPress plugin through 2.0.4 does not sanitise its heading_text and CSS settings, allowing high privilege users (admin) to set XSS payloads in them, leading to Stored Cross-Site Scripting issues.

NVD CVE-2021-24482WPScan advisorym0ze.ru

medium 5.4 CVE-2021-24180 · published 2021-04-05

Reflected cross-site scripting (XSS) in Related Posts for WordPress (older than 2.0.4)

Affected
older than 2.0.4
Fixed in
2.0.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

Unvalidated input and lack of output encoding within the Related Posts for WordPress plugin before 2.0.4 lead to a Reflected Cross-Site Scripting (XSS) vulnerability within the 'lang' GET parameter while editing a post, triggered when users with the capability of editing posts access a malicious URL.

NVD CVE-2021-24180WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Related Posts for WordPress vulnerability status badge
<a href="https://laskyr.com/plugins/related-posts-for-wp"><img src="https://laskyr.com/plugins/related-posts-for-wp/badge.svg" alt="Related Posts for WordPress vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit