Skip to content
Laskyr

Plugins · related-posts-by-taxonomy · data as of 2026-11-04

Is Related Posts by Taxonomy safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.7.10)

As of 2026-11-04. 1 issue is on record for older versions; version 2.7.7 or newer fixes all of them that state a fix.

Latest version
2.7.10
Last updated
2026-08-21
Active installs
10,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4

Display a list of related posts on your site based on the most terms in common. Supports thumbnails, shortcodes, a widget and more. — by keesiemeijer

What to do

  1. Update to the latest version (2.7.10). Anything older than 2.7.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get related-posts-by-taxonomy --field=version shows what you run; wp plugin update related-posts-by-taxonomy updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-0916 · published 2026-01-16

Stored cross-site scripting (XSS) in Related Posts by Taxonomy (2.7.6 and older)

Affected
2.7.6 and older
Fixed in
2.7.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Related Posts by Taxonomy plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'related_posts_by_tax' shortcode in all versions up to, and including, 2.7.6 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-0916Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Related Posts by Taxonomy vulnerability status badge
<a href="https://laskyr.com/plugins/related-posts-by-taxonomy"><img src="https://laskyr.com/plugins/related-posts-by-taxonomy/badge.svg" alt="Related Posts by Taxonomy vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit