Plugins · reepay-checkout-gateway · data as of 2026-11-04
Is Frisbii Pay safe? Known vulnerabilities and latest version
- Latest version
- 1.8.21
- Last updated
- 2026-10-31
- Active installs
- 1,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Accept Visa, MasterCard, Dankort, MobilePay, American Express, Diners Club and more directly on your store with the Frisbii Pay Gateway. — by Frisbii
What to do
- Update to the latest version (1.8.21). Anything older than 1.8.20 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get reepay-checkout-gateway --field=version shows what you run; wp plugin update reepay-checkout-gateway updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 8.8 CVE-2026-118076 · published 2026-10-29
PHP object injection in Frisbii Pay (1.8.19 and older)
- Affected
- 1.8.19 and older
- Fixed in
- 1.8.20 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Contributor PHP Object Injection in Frisbii Pay <= 1.8.19 versions.
medium 6.5 CVE-2026-3462 · published 2026-06-27
Missing authorization check in Frisbii Pay (1.8.9 and older)
- Affected
- 1.8.9 and older
- Fixed in
- 1.8.10 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Frisbii Pay plugin for WordPress is vulnerable to unauthorized modification of data due to missing capability checks on the 'upload_csv' and 'process_batch' functions in all versions up to, and including, 1.8.9. This makes it possible for authenticated attackers, with Subscriber-level access and above, to upload arbitrary CSV data and overwrite WooCommerce payment tokens, postmeta, and order meta records.
NVD CVE-2026-3462Wordfence advisoryCode change (fix)Plugin source
high 8.8 CVE-2026-56038 · published 2026-06-26
Privilege escalation in Frisbii Pay (1.8.2 and older)
- Affected
- 1.8.2 and older
- Fixed in
- 1.8.2.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Contributor Privilege Escalation in Frisbii Pay <= 1.8.2 versions.
medium 6.5 CVE-2025-58616 · published 2025-09-03
Missing authorization check in Frisbii Pay (1.8.2.1 and older)
- Affected
- 1.8.2.1 and older
- Fixed in
- 1.8.3
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Frisbii Frisbii Pay reepay-checkout-gateway allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Frisbii Pay: from n/a through <= 1.8.2.1.
Recent activity
- 2026-10-31 — latest release on wordpress.org (1.8.21).
- 2026-10-29 — PHP object injection disclosed (CVE-2026-118076), fixed in 1.8.20.
- 2026-06-27 — Missing authorization check disclosed (CVE-2026-3462), fixed in 1.8.10.
- 2026-06-26 — Privilege escalation disclosed (CVE-2026-56038), fixed in 1.8.2.1.
Get an email when Frisbii Pay has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Frisbii Pay (reepay-checkout-gateway) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (2) · PHP object injection (1) · Privilege escalation (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/reepay-checkout-gateway (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/reepay-checkout-gateway"><img src="https://laskyr.com/plugins/reepay-checkout-gateway/badge.svg" alt="Frisbii Pay vulnerability status"></a>