Skip to content
Laskyr

Plugins · record-of-consent-extension-for-complianz · data as of 2026-11-04

Is Record of Consent Extension for Complianz safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.7.1)

As of 2026-11-04. 1 issue is on record for older versions; version 2.6 or newer fixes all of them that state a fix.

Latest version
2.7.1
Last updated
2026-10-26
Active installs
600+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Stores custom consent records triggered by Complianz events with compliance tracking and auditing capabilities. — by davidevalerio

What to do

  1. Update to the latest version (2.7.1). Anything older than 2.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get record-of-consent-extension-for-complianz --field=version shows what you run; wp plugin update record-of-consent-extension-for-complianz updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-107631 · published 2026-10-14

Stored cross-site scripting (XSS) in Record of Consent Extension for Complianz (2.5 and older)

Affected
2.5 and older
Fixed in
2.6 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Record of Consent Extension for Complianz plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'uid' parameter in all versions up to, and including, 2.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is possible because the enforcing nonce is emitted via wp_localize_script on wp_enqueue_scripts and is therefore readable by any unauthenticated frontend visitor, and no capability or role check gates the write path.

NVD CVE-2026-107631Wordfence advisoryCode change (fix)wordpress.orgPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Record of Consent Extension for Complianz vulnerability status badge
<a href="https://laskyr.com/plugins/record-of-consent-extension-for-complianz"><img src="https://laskyr.com/plugins/record-of-consent-extension-for-complianz/badge.svg" alt="Record of Consent Extension for Complianz vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit