Skip to content
Laskyr

Plugins · recipe-card-blocks-by-wpzoom · data as of 2026-11-04

Is Recipe Card Blocks Lite safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.6.4)

As of 2026-11-04. 8 issues are on record for older versions; version 3.6.4 or newer fixes all of them that state a fix.

Latest version
3.6.4
Last updated
2026-10-22
Active installs
10,000+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Recipe Card Blocks with Schema Markup — create SEO-optimized recipes with Gutenberg, Elementor & AMP support — by WPZOOM

What to do

  1. Update to the latest version (3.6.4). Anything older than 3.6.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get recipe-card-blocks-by-wpzoom --field=version shows what you run; wp plugin update recipe-card-blocks-by-wpzoom updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-115282 · published 2026-10-29

Information disclosure in Recipe Card Blocks Lite (2.6.4 up to (not including) 3.6.4)

Affected
2.6.4 up to (not including) 3.6.4
Fixed in
3.6.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Recipe Card Blocks Lite WordPress plugin before 3.6.4 does not perform an authorization check before rendering posts through its recipe print feature, allowing unauthenticated users to disclose the title, ID and recipe content of unpublished posts, including drafts, pending, private and password-protected posts, that contain a recipe card block. Its optional "print only published posts" protection does not prevent this, because the status check is applied to a different post than the one ultimately rendered.

NVD CVE-2026-115282WPScan advisory

medium 6.8 CVE-2026-115281 · published 2026-10-28

SQL injection in Recipe Card Blocks Lite (3.5.0 up to (not including) 3.6.4)

Affected
3.5.0 up to (not including) 3.6.4
Fixed in
3.6.4
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Recipe Card Blocks Lite WordPress plugin before 3.6.4 does not sanitize and cast a block and shortcode attribute before concatenating it into SQL queries, allowing authenticated users with Contributor-level access or above to perform SQL injection attacks.

NVD CVE-2026-115281WPScan advisory

high 7.1 CVE-2026-73361 · published 2026-08-18

Cross-site scripting (XSS) in Recipe Card Blocks Lite (3.4.18 and older)

Affected
3.4.18 and older
Fixed in
3.4.19
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Recipe Card Blocks for Gutenberg & Elementor <= 3.4.18 versions.

NVD CVE-2026-73361Patchstack advisory

medium 6.4 CVE-2026-3011 · published 2026-06-08

Stored cross-site scripting (XSS) in Recipe Card Blocks Lite (3.4.13 and older)

Affected
3.4.13 and older
Fixed in
3.4.14 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Recipe Card Blocks Lite plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the recipe block's 'summary' and 'notes' attributes in all versions up to, and including, 3.4.13. This is due to the 'WPZOOM_Helpers::deserialize_block_attributes' method converting unicode-encoded sequences back into HTML characters after sanitization has already been applied. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that execute whenever a user accesses the published post or the print view of an injected recipe.

NVD CVE-2026-3011Wordfence advisoryCode change (fix)Plugin source

medium 6.8 CVE-2025-14973 · published 2026-01-26

SQL injection in Recipe Card Blocks Lite (older than 3.4.13)

Affected
older than 3.4.13
Fixed in
3.4.13
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Recipe Card Blocks Lite WordPress plugin before 3.4.13 does not sanitize and escape a parameter before using it in a SQL statement, allowing contributors and above to perform SQL injection attacks.

NVD CVE-2025-14973WPScan advisory

medium 6.5 CVE-2025-62019 · published 2025-10-22

Missing authorization check in Recipe Card Blocks Lite (3.4.8 and older)

Affected
3.4.8 and older
Fixed in
3.4.9
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WPZOOM Recipe Card Blocks for Gutenberg & Elementor recipe-card-blocks-by-wpzoom.This issue affects Recipe Card Blocks for Gutenberg & Elementor: from n/a through <= 3.4.8.

NVD CVE-2025-62019Patchstack advisory

medium 4.3 CVE-2025-26983 · published 2025-02-25

Missing authorization check in Recipe Card Blocks Lite (3.4.3 and older)

Affected
3.4.3 and older
Fixed in
3.4.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WPZOOM Recipe Card Blocks for Gutenberg & Elementor recipe-card-blocks-by-wpzoom allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Recipe Card Blocks for Gutenberg & Elementor: from n/a through <= 3.4.3.

NVD CVE-2025-26983Patchstack advisory

high 8.8 CVE-2024-43293 · published 2024-11-01

Missing authorization check in Recipe Card Blocks Lite (3.3.1 and older)

Affected
3.3.1 and older
Fixed in
3.3.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Missing Authorization vulnerability in WPZOOM Recipe Card Blocks for Gutenberg & Elementor allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Recipe Card Blocks for Gutenberg & Elementor: from n/a through 3.3.1.

NVD CVE-2024-43293Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Recipe Card Blocks Lite vulnerability status badge
<a href="https://laskyr.com/plugins/recipe-card-blocks-by-wpzoom"><img src="https://laskyr.com/plugins/recipe-card-blocks-by-wpzoom/badge.svg" alt="Recipe Card Blocks Lite vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit