Skip to content
Laskyr

Plugins · real-cookie-banner · data as of 2026-11-04

Is Real Cookie Banner safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.4.0)

As of 2026-11-04. 4 issues are on record for older versions; version 5.3.6 or newer fixes all of them that state a fix.

Latest version
5.4.0
Last updated
2026-10-14
Active installs
100,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4.0+

Obtain GDPR (DSGVO/RGPD) and ePrivacy Directive (TDDDG/TTDSG, LOPD-GDD, DTA) compliant consents in your cookie banner. More than just a cookie notice! — by devowl.io GmbH

What to do

  1. Update to the latest version (5.4.0). Anything older than 5.3.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get real-cookie-banner --field=version shows what you run; wp plugin update real-cookie-banner updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-92977 · published 2026-10-03

Stored cross-site scripting (XSS) in Real Cookie Banner (5.3.5 and older)

Affected
5.3.5 and older
Fixed in
5.3.6 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Real Cookie Banner: GDPR & ePrivacy Cookie Consent plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Comment in all versions up to, and including, 5.3.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Malicious script payloads placed in the title attribute of an anchor tag survive WordPress's comment kses filter at save time, as the payload is only promoted to executable HTML attributes when the plugin's page-wide regex strips the closing quote delimiter at render time; exploitability is therefore subject to the standard comment moderation workflow before the comment is publicly displayed.

NVD CVE-2026-92977Wordfence advisoryCode change (fix)Plugin source

medium 6.8 CVE-2025-12136 · published 2025-10-24

Server-side request forgery (SSRF) in Real Cookie Banner (5.2.4 and older)

Affected
5.2.4 and older
Fixed in
5.2.5 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Real Cookie Banner: GDPR & ePrivacy Cookie Consent plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 5.2.4. This is due to insufficient validation on the user-supplied URL in the '/scanner/scan-without-login' REST API endpoint. This makes it possible for authenticated attackers, with administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services via the `url` parameter.

NVD CVE-2025-12136Wordfence advisoryCode change (fix)infosecstuff.comowasp.orgPlugin source

medium 4.8 CVE-2025-1485 · published 2025-06-02

Stored cross-site scripting (XSS) in Real Cookie Banner (older than 5.1.6)

Affected
older than 5.1.6
Fixed in
5.1.6
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Real Cookie Banner: GDPR & ePrivacy Cookie Consent WordPress plugin before 5.1.6, real-cookie-banner-pro WordPress plugin before 5.1.6 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

NVD CVE-2025-1485WPScan advisory

medium 5.4 CVE-2022-4507 · published 2023-01-16

Stored cross-site scripting (XSS) in Real Cookie Banner (older than 3.4.10)

Affected
older than 3.4.10
Fixed in
3.4.10
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Real Cookie Banner WordPress plugin before 3.4.10 does not validate and escapes some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as a contributor to perform Stored Cross-Site Scripting attacks against logged-in admins.

NVD CVE-2022-4507WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Real Cookie Banner vulnerability status badge
<a href="https://laskyr.com/plugins/real-cookie-banner"><img src="https://laskyr.com/plugins/real-cookie-banner/badge.svg" alt="Real Cookie Banner vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit