Plugins · reactpress · data as of 2026-11-04
Is ReactPress safe? Known vulnerabilities and latest version
- Latest version
- 3.4.1
- Last updated
- 2026-10-23
- Active installs
- 2,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.0+
Easily create, build and deploy React apps into your existing WordPress sites. — by rockiger
What to do
- Update to the latest version (3.4.1). Anything older than 3.4.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get reactpress --field=version shows what you run; wp plugin update reactpress updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-92712 · published 2026-09-30
Stored cross-site scripting (XSS) in ReactPress (3.4.0 and older)
- Affected
- 3.4.0 and older
- Fixed in
- 3.4.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The ReactPress – Create React App for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'permalink' parameter in all versions up to, and including, 3.4.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is possible because the permalink parameter is only passed through sanitize_url(), which does not prevent fetching attacker-controlled remote URLs whose response body — including script tags and event-handler attributes — is written verbatim to disk via file_put_contents().
medium 6.0 CVE-2026-66455 · published 2026-08-13
Missing authorization check in ReactPress (3.4.0 and older)
- Affected
- 3.4.0 and older
- Fixed in
- 3.4.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Subscriber Broken Access Control in ReactPress <= 3.4.0 versions.
Recent activity
- 2026-10-23 — latest release on wordpress.org (3.4.1).
- 2026-09-30 — Stored cross-site scripting (XSS) disclosed (CVE-2026-92712), fixed in 3.4.1.
- 2026-08-13 — Missing authorization check disclosed (CVE-2026-66455), fixed in 3.4.1.
Get an email when ReactPress has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for ReactPress (reactpress) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/reactpress (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/reactpress"><img src="https://laskyr.com/plugins/reactpress/badge.svg" alt="ReactPress vulnerability status"></a>