Skip to content
Laskyr

Plugins · ravpage · data as of 2026-11-04

Is ravpage safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.41)

As of 2026-11-04. 3 issues are on record for older versions; version 2.41 or newer fixes all of them that state a fix.

Latest version
2.41
Last updated
2026-06-14
Active installs
300+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.0+

Publish landing pages created in Rav Messer directly on your WordPress site. — by Rav Messer

What to do

  1. Update to the latest version (2.41). Anything older than 2.41 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get ravpage --field=version shows what you run; wp plugin update ravpage updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2025-68835 · published 2026-01-22

Reflected cross-site scripting (XSS) in ravpage (2.33 and older)

Affected
2.33 and older
Fixed in
2.41 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in matiskiba Ravpage ravpage allows Reflected XSS.This issue affects Ravpage: from n/a through <= 2.33.

NVD CVE-2025-68835Patchstack advisory

critical 9.8 CVE-2024-13789 · published 2025-02-20

PHP object injection in ravpage (2.31 and older)

Affected
2.31 and older
Fixed in
2.33 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The ravpage plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 2.31 via deserialization of untrusted input from the 'paramsv2' parameter. This makes it possible for unauthenticated attackers to inject a PHP Object. No known POP chain is present in the vulnerable software, which means this vulnerability has no impact unless another plugin or theme containing a POP chain is installed on the site. If a POP chain is present via an additional plugin or theme installed on the target system, it may allow the attacker to perform actions like delete arbitrary files, retrieve sensitive data, or execute code depending on the POP chain present.

NVD CVE-2024-13789Wordfence advisoryCode change (fix)Plugin source

medium 6.1 CVE-2022-29415 · published 2022-04-28

Reflected cross-site scripting (XSS) in ravpage (2.16 and older)

Affected
2.16 and older
Fixed in
2.18 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unauthenticated Reflected Cross-Site Scripting (XSS) vulnerability in Mati Skiba @ Rav Messer's Ravpage plugin <= 2.16 at WordPress.

NVD CVE-2022-29415Patchstack advisorywordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
ravpage vulnerability status badge
<a href="https://laskyr.com/plugins/ravpage"><img src="https://laskyr.com/plugins/ravpage/badge.svg" alt="ravpage vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit