Skip to content
Laskyr

Plugins · rate-star-review · data as of 2026-11-04

Is Rate Star Review Vote safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.6.9)

As of 2026-11-04. 3 issues are on record for older versions; version 1.6.5 or newer fixes all of them that state a fix.

Latest version
1.6.9
Last updated
2026-10-10
Active installs
30+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Boost engagement with AJAX-driven star ratings, reviews, vote buttons for content. Includes a bundled runtime subset of Fomantic UI 2.9. — by videowhisper

What to do

  1. Update to the latest version (1.6.9). Anything older than 1.6.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get rate-star-review --field=version shows what you run; wp plugin update rate-star-review updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-4301 · published 2026-05-12

Missing authorization check in Rate Star Review Vote (1.6.4 and older)

Affected
1.6.4 and older
Fixed in
1.6.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Rate Star Review Vote - AJAX Reviews, Votes, Star Ratings plugin for WordPress is vulnerable to Missing Authorization in all versions up to and including 1.6.4. The vwrsr_review() AJAX handler lacks both capability checks and nonce verification. The only access control is an is_user_logged_in() check. When the 'form' parameter is set to 'update', the function takes an arbitrary post ID from the user-supplied 'rating_id' GET parameter, sets it as the post ID in the update array, and passes it directly to wp_update_post(). This overwrites the target post's title, content, author (changed to the attacker's user ID), post_type (changed to the plugin's custom post type, default 'review'), and status. Additionally, update_post_meta() is called on the arbitrary post ID at lines 758-763, modifying its metadata. This makes it possible for authenticated attackers, with Subscriber-level access and above, to modify the title, content, author, post type, and metadata of arbitrary posts and pages on the site via the 'rating_id' parameter, effectively allowing full post content takeover.

NVD CVE-2026-4301Wordfence advisoryPlugin source

medium 6.4 CVE-2024-13392 · published 2025-01-18

Stored cross-site scripting (XSS) in Rate Star Review Vote (1.6.3 and older)

Affected
1.6.3 and older
Fixed in
1.6.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Rate Star Review Vote – AJAX Reviews, Votes, Star Ratings plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'videowhisper_reviews' shortcode in all versions up to, and including, 1.6.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-13392Wordfence advisoryCode change (fix)

medium 6.1 CVE-2023-52213 · published 2024-01-08

Reflected cross-site scripting (XSS) in Rate Star Review Vote (1.5.1 and older)

Affected
1.5.1 and older
Fixed in
1.5.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in VideoWhisper Rate Star Review – AJAX Reviews for Content, with Star Ratings allows Reflected XSS.This issue affects Rate Star Review – AJAX Reviews for Content, with Star Ratings: from n/a through 1.5.1.

NVD CVE-2023-52213Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Rate Star Review Vote vulnerability status badge
<a href="https://laskyr.com/plugins/rate-star-review"><img src="https://laskyr.com/plugins/rate-star-review/badge.svg" alt="Rate Star Review Vote vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit