Skip to content
Laskyr

Plugins · quotes-llama · data as of 2026-11-04

Is Quotes llama safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.7)

As of 2026-11-04. 6 issues are on record for older versions; version 3.1.6 or newer fixes all of them that state a fix.

Latest version
3.1.7
Last updated
2026-06-26
Active installs
1,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.0.8

Create a collection of quotes. — by oooorgle

What to do

  1. Update to the latest version (3.1.7). Anything older than 3.1.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get quotes-llama --field=version shows what you run; wp plugin update quotes-llama updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.6 CVE-2026-12512 · published 2026-07-15

SQL injection in Quotes llama (older than 3.1.6)

Affected
older than 3.1.6
Fixed in
3.1.6
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Quotes llama WordPress plugin before 3.1.6 does not properly sanitize and escape a user-supplied parameter before using it in a SQL query, allowing unauthenticated attackers to perform UNION-based SQL injection and read arbitrary data from the database, including password hashes.

NVD CVE-2026-12512WPScan advisory

critical 9.3 CVE-2026-56062 · published 2026-06-26

SQL injection in Quotes llama (3.1.5 and older)

Affected
3.1.5 and older
Fixed in
3.1.6
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated SQL Injection in Quotes llama <= 3.1.5 versions.

NVD CVE-2026-56062Patchstack advisory

medium 6.5 CVE-2025-30786 · published 2025-03-27

Cross-site scripting (XSS) in Quotes llama (3.1.0 and older)

Affected
3.1.0 and older
Fixed in
3.1.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in oooorgle Quotes llama quotes-llama allows DOM-Based XSS.This issue affects Quotes llama: from n/a through <= 3.1.0.

NVD CVE-2025-30786Patchstack advisory

medium 6.5 CVE-2025-27307 · published 2025-02-24

Reflected cross-site scripting (XSS) in Quotes llama (3.0.1 and older)

Affected
3.0.1 and older
Fixed in
3.0.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in oooorgle Quotes llama quotes-llama allows Reflected XSS.This issue affects Quotes llama: from n/a through <= 3.0.1.

NVD CVE-2025-27307Patchstack advisory

medium 6.4 CVE-2024-10874 · published 2024-11-23

Stored cross-site scripting (XSS) in Quotes llama (3.0.0 and older)

Affected
3.0.0 and older
Fixed in
3.0.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Quotes llama plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'quotes-llama' shortcode in all versions up to, and including, 3.0.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-10874Wordfence advisoryCode change (fix)Plugin source

medium 4.8 CVE-2022-1566 · published 2022-05-30

Cross-site scripting (XSS) in Quotes llama (older than 1.0.0)

Affected
older than 1.0.0
Fixed in
1.0.0
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The Quotes llama WordPress plugin before 1.0.0 does not sanitise and escape Quotes, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed. The attack could also be performed by tricking an admin to import a malicious CSV file

NVD CVE-2022-1566WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Quotes llama vulnerability status badge
<a href="https://laskyr.com/plugins/quotes-llama"><img src="https://laskyr.com/plugins/quotes-llama/badge.svg" alt="Quotes llama vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit