Skip to content
Laskyr

Plugins · quillforms · data as of 2026-11-04

Is Quill Forms safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.7.6)

As of 2026-11-04. 6 issues are on record for older versions; version 5.7.2 or newer fixes all of them that state a fix.

Latest version
5.7.6
Last updated
2026-10-13
Active installs
3,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.1+

Quill Forms - Conversational WordPress Form Builder — by Mohamed Magdy

What to do

  1. Update to the latest version (5.7.6). Anything older than 5.7.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get quillforms --field=version shows what you run; wp plugin update quillforms updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-15664 · published 2026-09-19

Stored cross-site scripting (XSS) in Quill Forms (5.7.1 and older)

Affected
5.7.1 and older
Fixed in
5.7.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Quill Forms | Conversational Multi Step Forms, Surveys & quizzes plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Multiple Choice 'Other' Value in all versions up to, and including, 5.7.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The injected script executes in the context of the WordPress admin results view, making administrators the primary target when reviewing submitted form entries.

NVD CVE-2026-15664Wordfence advisoryCode change (fix)Plugin source

high 7.1 CVE-2026-28568 · published 2026-08-18

Cross-site scripting (XSS) in Quill Forms (5.7.1 and older)

Affected
5.7.1 and older
Fixed in
5.7.2 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Quill Forms <= 5.7.1 versions.

NVD CVE-2026-28568Patchstack advisory

high 7.2 CVE-2026-75091 · published 2026-08-18

Stored cross-site scripting (XSS) in Quill Forms (5.7.1 and older)

Affected
5.7.1 and older
Fixed in
5.7.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Quill Forms | Conversational Multi Step Forms, Surveys & quizzes plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 5.7.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-75091Wordfence advisoryPatchstack advisory

medium 6.4 CVE-2024-11826 · published 2025-01-07

Stored cross-site scripting (XSS) in Quill Forms (3.10.0 and older)

Affected
3.10.0 and older
Fixed in
4.0.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Quill Forms | The Best Typeform Alternative | Create Conversational Multi Step Form, Survey, Quiz, Cost Estimation or Donation Form on WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'quillforms-popup' shortcode in all versions up to, and including, 3.10.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-11826Wordfence advisoryCode change (fix)

medium 6.5 CVE-2023-46610 · published 2025-01-02

Missing authorization check in Quill Forms (3.3.0 and older)

Affected
3.3.0 and older
Fixed in
3.4.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Mohamed Magdy Quill Forms quillforms allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Quill Forms: from n/a through <= 3.3.0.

NVD CVE-2023-46610Patchstack advisory

medium 6.5 CVE-2024-47393 · published 2024-10-05

Stored cross-site scripting (XSS) in Quill Forms (3.7.0 and older)

Affected
3.7.0 and older
Fixed in
3.8.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Mohamed Magdy Quill Forms quillforms allows Stored XSS.This issue affects Quill Forms: from n/a through <= 3.7.0.

NVD CVE-2024-47393Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Quill Forms vulnerability status badge
<a href="https://laskyr.com/plugins/quillforms"><img src="https://laskyr.com/plugins/quillforms/badge.svg" alt="Quill Forms vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit