Plugins · quick-restaurant-reservations · data as of 2026-11-04
Is Quick Restaurant Reservations safe? Known vulnerabilities and latest version
- Latest version
- 1.6.7
- Last updated
- 2023-04-02
- Active installs
- 500+
- Known issues on record
- 3
- Unpatched in latest
- 1
- Tested up to WP
- 6.2.15
Manage restaurant reservations the easiest way. — by Alejandro
What to do
- There is no fixed version yet. If you can live without Quick Restaurant Reservations for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get quick-restaurant-reservations --field=version shows what you run; wp plugin update quick-restaurant-reservations updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 affects latest 1.6.7 CVE-2026-24529 · published 2026-01-23
Missing authorization check in Quick Restaurant Reservations (1.6.7 and older)
- Affected
- 1.6.7 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Alejandro Quick Restaurant Reservations quick-restaurant-reservations allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Quick Restaurant Reservations: from n/a through <= 1.6.7.
critical 9.8 CVE-2022-44739 · published 2023-05-22
Cross-site request forgery (CSRF) in Quick Restaurant Reservations (1.5.4 and older)
- Affected
- 1.5.4 and older
- Fixed in
- 1.5.5
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in ThingsForRestaurants Quick Restaurant Reservations plugin <= 1.5.4 versions.
medium 4.8 CVE-2022-29923 · published 2022-07-20
Reflected cross-site scripting (XSS) in Quick Restaurant Reservations (1.4.1 and older)
- Affected
- 1.4.1 and older
- Fixed in
- 1.4.2
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-site Scripting (XSS) vulnerability in ThingsForRestaurants Quick Restaurant Reservations (WordPress plugin) allows Reflected XSS.This issue affects Quick Restaurant Reservations (WordPress plugin): from n/a through 1.4.1.
Recent activity
- 2023-04-02 — latest release on wordpress.org (1.6.7).
- 2026-01-23 — Missing authorization check disclosed (CVE-2026-24529), no fix listed yet.
- 2023-05-22 — Cross-site request forgery (CSRF) disclosed (CVE-2022-44739), fixed in 1.5.5.
- 2022-07-20 — Reflected cross-site scripting (XSS) disclosed (CVE-2022-29923), fixed in 1.4.2.
Get an email when Quick Restaurant Reservations has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Quick Restaurant Reservations (quick-restaurant-reservations) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1) · Cross-site request forgery (CSRF) (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/quick-restaurant-reservations (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/quick-restaurant-reservations"><img src="https://laskyr.com/plugins/quick-restaurant-reservations/badge.svg" alt="Quick Restaurant Reservations vulnerability status"></a>