Skip to content
Laskyr

Plugins · quick-playground · data as of 2026-11-04

Is Quick Playground safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.3.6)

As of 2026-11-04. 3 issues are on record for older versions; version 1.3.5 or newer fixes all of them that state a fix.

Latest version
1.3.6
Last updated
2026-08-24
Active installs
10+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4

Simplify creation of WordPress Playground test, staging, and demo sites. Specify the theme, plugins and content from the WP admin dashboard. — by davidfcarr

What to do

  1. Update to the latest version (1.3.6). Anything older than 1.3.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get quick-playground --field=version shows what you run; wp plugin update quick-playground updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.4 CVE-2026-2500 · published 2026-06-06

Path traversal / file read in Quick Playground (1.3.4 and older)

Affected
1.3.4 and older
Fixed in
1.3.5 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Quick Playground plugin for WordPress is vulnerable to Path Traversal in all versions up to, and including, 1.3.4. This is due to the `qckply_data()` function passing the user-supplied `filename` POST parameter directly to `file_get_contents()` without any validation, sanitization, or path restriction. This makes it possible for authenticated attackers, with Administrator-level access and above, to read arbitrary files on the server, such as `wp-config.php` or `/etc/passwd`, which can contain sensitive information. Note: This vulnerability is only exploitable when the site has been synced with WordPress Playground (the `is_qckply_clone` option is set) or when running on `playground.wordpress.net`.

NVD CVE-2026-2500Wordfence advisoryCode change (fix)Plugin source

high 7.5 CVE-2026-6403 · published 2026-05-15

Path traversal / file read in Quick Playground (1.3.3 and older)

Affected
1.3.3 and older
Fixed in
1.3.4 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Quick Playground plugin for WordPress is vulnerable to Path Traversal in versions up to and including 1.3.3. This is due to insufficient path validation in the qckply_zip_theme() function, which appends a user-controlled 'stylesheet' parameter directly to the theme root directory path without sanitizing directory traversal sequences. This makes it possible for unauthenticated attackers to trigger the creation of a ZIP archive containing arbitrary files from the server's filesystem — including wp-config.

NVD CVE-2026-6403Wordfence advisoryCode change (fix)Plugin source

critical 9.8 CVE-2026-1830 · published 2026-04-09

Arbitrary file upload in Quick Playground (1.3.1 and older)

Affected
1.3.1 and older
Fixed in
1.3.2 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Quick Playground plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1.3.1. This is due to insufficient authorization checks on REST API endpoints that expose a sync code and allow arbitrary file uploads. This makes it possible for unauthenticated attackers to retrieve the sync code, upload PHP files with path traversal, and achieve remote code execution on the server.

NVD CVE-2026-1830Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Quick Playground vulnerability status badge
<a href="https://laskyr.com/plugins/quick-playground"><img src="https://laskyr.com/plugins/quick-playground/badge.svg" alt="Quick Playground vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit