Skip to content
Laskyr

Plugins · quick-paypal-payments · data as of 2026-11-04

Is Quick PayPal Payments safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (6.0.5)

As of 2026-11-04. 9 issues are on record for older versions; version 6.0.5 or newer fixes all of them that state a fix.

Latest version
6.0.5
Last updated
2026-10-14
Active installs
1,000+
Known issues on record
9
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Add a PayPal button, payment form or donation box with a shortcode. Unlimited forms, any currency, no business account needed. — by fullworks

What to do

  1. Update to the latest version (6.0.5). Anything older than 6.0.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get quick-paypal-payments --field=version shows what you run; wp plugin update quick-paypal-payments updates it.

Check your version

Known vulnerabilities

9 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-110017 · published 2026-10-16

Stored cross-site scripting (XSS) in Quick PayPal Payments (6.0.4 and older)

Affected
6.0.4 and older
Fixed in
6.0.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Quick PayPal Payments: Payment Button & Form plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'form' parameter in all versions up to, and including, 6.0.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Because wp_kses_post strips only HTML tags, a quote-breaking payload containing no angle brackets survives post save intact, and the injected script fires for every viewer of the post — including higher-privileged Editors and Administrators who routinely preview a Contributor's pending content.

NVD CVE-2026-110017Wordfence advisoryCode change (fix)Plugin source

medium 5.3 CVE-2026-108492 · published 2026-10-13

Missing authorization check in Quick PayPal Payments (6.0.3 and older)

Affected
6.0.3 and older
Fixed in
6.0.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Fullworks Plugins Quick Paypal Payments quick-paypal-payments allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Quick Paypal Payments: from n/a through 6.0.3.

NVD CVE-2026-108492Patchstack advisory

medium 5.3 CVE-2026-17008 · published 2026-08-12

Security issue in Quick PayPal Payments (5.7.50 and older)

Affected
5.7.50 and older
Fixed in
5.7.51 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by WPScan
Details from the advisory

The Quick Paypal Payments WordPress plugin through 5.7.50 does not verify the paid amount, receiver, or payment status in its PayPal IPN handler and marks an order paid on an order-token match alone, so a buyer who pays an arbitrary small amount can have a full-price order marked paid.

NVD CVE-2026-17008WPScan advisory

medium 4.3 CVE-2025-27003 · published 2025-09-05

Cross-site request forgery (CSRF) in Quick PayPal Payments (5.7.46 and older)

Affected
5.7.46 and older
Fixed in
5.7.47
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in fullworks Quick Paypal Payments quick-paypal-payments allows Cross Site Request Forgery.This issue affects Quick Paypal Payments: from n/a through <= 5.7.46.

NVD CVE-2025-27003Patchstack advisory

high 7.5 CVE-2023-25714 · published 2024-12-09

Missing authorization check in Quick PayPal Payments (5.7.25 and older)

Affected
5.7.25 and older
Fixed in
5.7.26
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Fullworks Quick Paypal Payments allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Quick Paypal Payments: from n/a through 5.7.25.

NVD CVE-2023-25714Patchstack advisory

medium 4.8 CVE-2023-1554 · published 2023-05-02

Stored cross-site scripting (XSS) in Quick PayPal Payments (older than 5.7.26.4)

Affected
older than 5.7.26.4
Fixed in
5.7.26.4
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Quick Paypal Payments WordPress plugin before 5.7.26.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

NVD CVE-2023-1554WPScan advisory

medium 5.4 CVE-2023-23889 · published 2023-04-25

Stored cross-site scripting (XSS) in Quick PayPal Payments (5.7.25 and older)

Affected
5.7.25 and older
Fixed in
5.7.26
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (contributor+) Stored Cross-Site Scripting (XSS) vulnerability in Fullworks Quick Paypal Payments plugin <= 5.7.25 versions.

NVD CVE-2023-23889Patchstack advisory

medium 4.8 CVE-2023-25702 · published 2023-04-07

Stored cross-site scripting (XSS) in Quick PayPal Payments (5.7.25 and older)

Affected
5.7.25 and older
Fixed in
5.7.25
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (admin+) Stored Cross-site Scripting (XSS) vulnerability in Fullworks Quick Paypal Payments plugin <= 5.7.25 versions.

NVD CVE-2023-25702Patchstack advisory

medium 6.1 CVE-2023-25713 · published 2023-04-07

Stored cross-site scripting (XSS) in Quick PayPal Payments (5.7.25 and older)

Affected
5.7.25 and older
Fixed in
5.7.26
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unauth. Stored Cross-Site Scripting (XSS) vulnerability in Fullworks Quick Paypal Payments plugin <= 5.7.25 versions.

NVD CVE-2023-25713Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Quick PayPal Payments vulnerability status badge
<a href="https://laskyr.com/plugins/quick-paypal-payments"><img src="https://laskyr.com/plugins/quick-paypal-payments/badge.svg" alt="Quick PayPal Payments vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit