Plugins · quick-interest-slider · data as of 2026-11-04
Is Quick Interest Slider safe? Known vulnerabilities and latest version
- Latest version
- 3.1.8
- Last updated
- 2026-07-16
- Active installs
- 1,000+
- Known issues on record
- 7
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8
A simple repayment calculator. Uses sliders to set the amount and term and displays a range of outputs — by Graham
What to do
- Update to the latest version (3.1.8). Anything older than 3.1.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get quick-interest-slider --field=version shows what you run; wp plugin update quick-interest-slider updates it.
Check your version
Known vulnerabilities
7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-56039 · published 2026-06-26
Cross-site scripting (XSS) in Quick Interest Slider (3.1.6 and older)
- Affected
- 3.1.6 and older
- Fixed in
- 3.1.7
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in Quick Interest Slider <= 3.1.6 versions.
high 7.2 CVE-2026-5694 · published 2026-04-15
Stored cross-site scripting (XSS) in Quick Interest Slider (3.1.5 and older)
- Affected
- 3.1.5 and older
- Fixed in
- 3.1.6 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Quick Interest Slider plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'loan-amount' and 'loan-period' parameters in all versions up to, and including, 3.1.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
medium 4.3 CVE-2025-64237 · published 2025-12-16
Cross-site request forgery (CSRF) in Quick Interest Slider (3.1.5 and older)
- Affected
- 3.1.5 and older
- Fixed in
- 3.1.6
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Graham Quick Interest Slider quick-interest-slider allows Cross Site Request Forgery.This issue affects Quick Interest Slider: from n/a through <= 3.1.5.
medium 5.3 CVE-2025-62153 · published 2025-12-09
Missing authorization check in Quick Interest Slider (3.1.7 and older)
- Affected
- 3.1.7 and older
- Fixed in
- 3.1.8 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Graham Quick Interest Slider quick-interest-slider allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Quick Interest Slider: from n/a through <= 3.1.7.
medium 6.5 CVE-2025-26738 · published 2025-03-27
Cross-site scripting (XSS) in Quick Interest Slider (3.1.5 and older)
- Affected
- 3.1.5 and older
- Fixed in
- 3.1.6 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Graham Quick Interest Slider quick-interest-slider allows DOM-Based XSS.This issue affects Quick Interest Slider: from n/a through <= 3.1.5.
medium 5.4 CVE-2024-31263 · published 2024-04-12
Cross-site request forgery (CSRF) in Quick Interest Slider (2.9.4 and older)
- Affected
- 2.9.4 and older
- Fixed in
- 2.9.5
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in aerin Loan Repayment Calculator and Application Form.This issue affects Loan Repayment Calculator and Application Form: from n/a through 2.9.4.
medium 4.8 CVE-2023-50829 · published 2023-12-21
Stored cross-site scripting (XSS) in Quick Interest Slider (2.9.3 and older)
- Affected
- 2.9.3 and older
- Fixed in
- 2.9.4 *
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Aerin Loan Repayment Calculator and Application Form allows Stored XSS.This issue affects Loan Repayment Calculator and Application Form: from n/a through 2.9.3.
Recent activity
- 2026-07-16 — latest release on wordpress.org (3.1.8).
- 2026-06-26 — Cross-site scripting (XSS) disclosed (CVE-2026-56039), fixed in 3.1.7.
- 2026-04-15 — Stored cross-site scripting (XSS) disclosed (CVE-2026-5694), fixed in 3.1.6.
- 2025-12-16 — Cross-site request forgery (CSRF) disclosed (CVE-2025-64237), fixed in 3.1.6.
Get an email when Quick Interest Slider has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Quick Interest Slider (quick-interest-slider) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (4) · Cross-site request forgery (CSRF) (2) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/quick-interest-slider (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/quick-interest-slider"><img src="https://laskyr.com/plugins/quick-interest-slider/badge.svg" alt="Quick Interest Slider vulnerability status"></a>