Plugins · quick-featured-images · data as of 2026-11-04
Is Quick Featured Images safe? Known vulnerabilities and latest version
- Latest version
- 13.7.5
- Last updated
- 2026-08-18
- Active installs
- 50,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 5.2+
The time-saving solution for managing tons of featured images within minutes: Set, replace and delete in bulk and set default images for future posts. — by Kybernetik Services
What to do
- Update to the latest version (13.7.5). Anything older than 13.7.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get quick-featured-images --field=version shows what you run; wp plugin update quick-featured-images updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.9 CVE-2025-11980 · published 2025-11-08
SQL injection in Quick Featured Images (13.7.3 and older)
- Affected
- 13.7.3 and older
- Fixed in
- 13.7.4 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Quick Featured Images plugin for WordPress is vulnerable to SQL Injection via the 'delete_orphaned' function in all versions up to, and including, 13.7.3 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Editor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database, granted they can convince an author-level user or higher to add a malicious custom field value.
NVD CVE-2025-11980Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2025-11176 · published 2025-10-15
Missing authorization check in Quick Featured Images (13.7.2 and older)
- Affected
- 13.7.2 and older
- Fixed in
- 13.7.3 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Quick Featured Images plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 13.7.2 via the qfi_set_thumbnail and qfi_delete_thumbnail AJAX actions due to missing validation on a user controlled key. This makes it possible for authenticated attackers, with Author-level access and above, to change or remove featured images of other user's posts.
NVD CVE-2025-11176Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2024-3664 · published 2024-04-23
Missing authorization check in Quick Featured Images (13.7.0 and older)
- Affected
- 13.7.0 and older
- Fixed in
- 13.7.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Quick Featured Images plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the set_thumbnail and delete_thumbnail functions in all versions up to, and including, 13.7.0. This makes it possible for authenticated attackers, with contributor-level access and above, to delete thumbnails and add thumbnails to posts they did not author.
Recent activity
- 2026-08-18 — latest release on wordpress.org (13.7.5).
- 2025-11-08 — SQL injection disclosed (CVE-2025-11980), fixed in 13.7.4.
- 2025-10-15 — Missing authorization check disclosed (CVE-2025-11176), fixed in 13.7.3.
- 2024-04-23 — Missing authorization check disclosed (CVE-2024-3664), fixed in 13.7.1.
Get an email when Quick Featured Images has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Quick Featured Images (quick-featured-images) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (2) · SQL injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/quick-featured-images (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/quick-featured-images"><img src="https://laskyr.com/plugins/quick-featured-images/badge.svg" alt="Quick Featured Images vulnerability status"></a>