Plugins · quick-event-manager · data as of 2026-11-04
Is Quick Event Manager safe? Known vulnerabilities and latest version
- Latest version
- 9.19.1
- Last updated
- 2026-10-29
- Active installs
- 1,000+
- Known issues on record
- 8
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Simple event manager. No messing about, just add events and a shortcode and the plugin does the rest for you. — by brightvesseldev
What to do
- Update to the latest version (9.19.1). Anything older than 9.19 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get quick-event-manager --field=version shows what you run; wp plugin update quick-event-manager updates it.
Check your version
Known vulnerabilities
8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-82214 · published 2026-10-31
Information disclosure in Quick Event Manager (8.4.6 up to (not including) 9.19)
- Affected
- 8.4.6 up to (not including) 9.19
- Fixed in
- 9.19
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Quick Event Manager WordPress plugin before 9.19 does not verify the status or type of the requested post before returning its details through a calendar export, allowing unauthenticated users to read the content of draft and private posts.
high 7.5 CVE-2026-84847 · published 2026-09-03
Missing authorization check in Quick Event Manager (9.17 and older)
- Affected
- 9.17 and older
- Fixed in
- 9.18 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Broken Access Control in Quick Event Manager <= 9.17 versions.
high 7.1 CVE-2026-84848 · published 2026-09-03
Cross-site scripting (XSS) in Quick Event Manager (9.17 and older)
- Affected
- 9.17 and older
- Fixed in
- 9.18 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in Quick Event Manager <= 9.17 versions.
medium 5.3 CVE-2023-23975 · published 2024-12-09
Missing authorization check in Quick Event Manager (9.7.4 and older)
- Affected
- 9.7.4 and older
- Fixed in
- 9.7.5
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Fullworks Quick Event Manager allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Quick Event Manager: from n/a through 9.7.4.
medium 6.1 CVE-2023-23979 · published 2023-04-06
Stored cross-site scripting (XSS) in Quick Event Manager (9.7.4 and older)
- Affected
- 9.7.4 and older
- Fixed in
- 9.7.5
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Unauth. Stored Cross-Site Scripting (XSS) vulnerability in Fullworks Quick Event Manager plugin <= 9.7.4 versions.
medium 4.8 CVE-2022-46863 · published 2023-03-28
Stored cross-site scripting (XSS) in Quick Event Manager (9.6.4 and older)
- Affected
- 9.6.4 and older
- Fixed in
- 9.6.5
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Fullworks Quick Event Manager plugin <= 9.6.4 versions.
medium 5.4 CVE-2023-23974 · published 2023-03-01
Cross-site request forgery (CSRF) in Quick Event Manager (9.7.4 and older)
- Affected
- 9.7.4 and older
- Fixed in
- 9.7.5
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Fullworks Quick Event Manager plugin <= 9.7.4 affecting all registration actions (delete, delete all, edit, update).
medium 6.1 CVE-2023-23491 · published 2023-01-20
Reflected cross-site scripting (XSS) in Quick Event Manager (older than 9.7.5)
- Affected
- older than 9.7.5
- Fixed in
- 9.7.5
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The Quick Event Manager WordPress Plugin, version < 9.7.5, is affected by a reflected cross-site scripting vulnerability in the 'category' parameter of its 'qem_ajax_calendar' action.
Recent activity
- 2026-10-29 — latest release on wordpress.org (9.19.1).
- 2026-10-31 — Information disclosure disclosed (CVE-2026-82214), fixed in 9.19.
- 2026-09-03 — Missing authorization check disclosed (CVE-2026-84847), fixed in 9.18.
- 2026-09-03 — Cross-site scripting (XSS) disclosed (CVE-2026-84848), fixed in 9.18.
Get an email when Quick Event Manager has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Quick Event Manager (quick-event-manager) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by brightvesseldev (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (4) · Missing authorization (2) · Sensitive data exposure (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/quick-event-manager (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/quick-event-manager"><img src="https://laskyr.com/plugins/quick-event-manager/badge.svg" alt="Quick Event Manager vulnerability status"></a>