Skip to content
Laskyr

Plugins · quick-contact-form · data as of 2026-11-04

Is Quick Contact Form safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (8.2.7)

As of 2026-11-04. 6 issues are on record for older versions; version 8.2.7 or newer fixes all of them that state a fix.

Latest version
8.2.7
Last updated
2026-01-06
Active installs
1,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
6.8.12 · PHP 5.6+

An easy to set up, plug and play contact form with a huge range of options and styles. A beginner friendly WordPress contact form plugin. — by Saad Iqbal

What to do

  1. Update to the latest version (8.2.7). Anything older than 8.2.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get quick-contact-form --field=version shows what you run; wp plugin update quick-contact-form updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.8 CVE-2025-12718 · published 2026-01-17

Security issue in Quick Contact Form (8.2.6 and older)

Affected
8.2.6 and older
Fixed in
8.2.7 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Quick Contact Form plugin for WordPress is vulnerable to Open Mail Relay in all versions up to, and including, 8.2.6. This is due to the 'qcf_validate_form' AJAX endpoint allowing a user controlled parameter to set the 'from' email address. This makes it possible for unauthenticated attackers to send emails to arbitrary recipients utilizing the server. The information is limited to the contact form submission details.

NVD CVE-2025-12718Wordfence advisoryCode change (fix)

medium 4.3 CVE-2025-67471 · published 2025-12-09

Cross-site request forgery (CSRF) in Quick Contact Form (8.2.5 and older)

Affected
8.2.5 and older
Fixed in
8.2.6
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Saad Iqbal Quick Contact Form quick-contact-form allows Cross Site Request Forgery.This issue affects Quick Contact Form: from n/a through <= 8.2.5.

NVD CVE-2025-67471Patchstack advisory

high 7.1 CVE-2025-48245 · published 2025-05-23

Reflected cross-site scripting (XSS) in Quick Contact Form (8.2.1 and older)

Affected
8.2.1 and older
Fixed in
8.2.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Saad Iqbal Quick Contact Form quick-contact-form allows Reflected XSS.This issue affects Quick Contact Form: from n/a through <= 8.2.1.

NVD CVE-2025-48245Patchstack advisory

medium 6.5 CVE-2023-25035 · published 2024-12-09

Missing authorization check in Quick Contact Form (8.0.3.1 and older)

Affected
8.0.3.1 and older
Fixed in
8.0.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Fullworks Quick Contact Form allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Quick Contact Form : from n/a through 8.0.3.1.

NVD CVE-2023-25035Patchstack advisory

medium 4.8 CVE-2022-47608 · published 2023-04-25

Stored cross-site scripting (XSS) in Quick Contact Form (8.0.3.1 and older)

Affected
8.0.3.1 and older
Fixed in
8.0.4
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Fullworks Quick Contact Form plugin <= 8.0.3.1 versions.

NVD CVE-2022-47608Patchstack advisory

medium 5.4 CVE-2023-23885 · published 2023-04-07

Stored cross-site scripting (XSS) in Quick Contact Form (8.0.3.1 and older)

Affected
8.0.3.1 and older
Fixed in
8.0.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (contributor+) Stored Cross-Site Scripting (XSS) vulnerability in Fullworks Quick Contact Form plugin <= 8.0.3.1 versions.

NVD CVE-2023-23885Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Quick Contact Form vulnerability status badge
<a href="https://laskyr.com/plugins/quick-contact-form"><img src="https://laskyr.com/plugins/quick-contact-form/badge.svg" alt="Quick Contact Form vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit