Skip to content
Laskyr

Plugins · quick-adsense-reloaded · data as of 2026-11-04

Is Quads Ads Manager for Google AdSense safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.0.5.1)

As of 2026-11-04. 9 issues are on record for older versions; version 3.0.5 or newer fixes all of them that state a fix.

Latest version
3.0.5.1
Last updated
2026-09-24
Active installs
20,000+
Known issues on record
9
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Ads & AdSense plugin supporting Media.net, DFP, ads.txt, Web Stories ads, click fraud protection, revenue sharing, and ad blocker detection. — by Ads by WPQuads

What to do

  1. Update to the latest version (3.0.5.1). Anything older than 3.0.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get quick-adsense-reloaded --field=version shows what you run; wp plugin update quick-adsense-reloaded updates it.

Check your version

Known vulnerabilities

9 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-89050 · published 2026-09-13

Security issue in Quads Ads Manager for Google AdSense (3.0.4 up to (not including) 3.0.5)

Affected
3.0.4 up to (not including) 3.0.5
Fixed in
3.0.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by WPScan
Details from the advisory

The Quads Ads Manager for Google AdSense WordPress plugin before 3.0.5 does not verify payment completion with the configured payment gateway before marking an ad-selling order as paid, allowing users who can place an order to obtain a paid ad placement without payment.

NVD CVE-2026-89050WPScan advisory

medium 6.5 CVE-2026-57335 · published 2026-06-29

Missing authorization check in Quads Ads Manager for Google AdSense (3.0.3 and older)

Affected
3.0.3 and older
Fixed in
3.0.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Broken Access Control in Ads by WPQuads <= 3.0.3 versions.

NVD CVE-2026-57335Patchstack advisory

high 7.5 CVE-2026-54824 · published 2026-06-26

Information disclosure in Quads Ads Manager for Google AdSense (3.0.3 and older)

Affected
3.0.3 and older
Fixed in
3.0.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Sensitive Data Exposure in Ads by WPQuads <= 3.0.3 versions.

NVD CVE-2026-54824Patchstack advisory

medium 6.5 CVE-2026-42744 · published 2026-05-27

Security issue in Quads Ads Manager for Google AdSense (3.0.2 and older)

Affected
3.0.2 and older
Fixed in
3.0.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Validation of Specified Quantity in Input vulnerability in Ads by WPQuads Ads by WPQuads quick-adsense-reloaded allows Manipulating Hidden Fields.This issue affects Ads by WPQuads: from n/a through <= 3.0.2.

NVD CVE-2026-42744Patchstack advisory

medium 6.5 CVE-2026-42732 · published 2026-05-27

Security issue in Quads Ads Manager for Google AdSense (3.0.2 and older)

Affected
3.0.2 and older
Fixed in
3.0.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Validation of Specified Quantity in Input vulnerability in Ads by WPQuads Ads by WPQuads quick-adsense-reloaded allows Input Data Manipulation.This issue affects Ads by WPQuads: from n/a through <= 3.0.2.

NVD CVE-2026-42732Patchstack advisory

medium 5.4 CVE-2026-2595 · published 2026-03-28

Stored cross-site scripting (XSS) in Quads Ads Manager for Google AdSense (2.0.98.1 and older)

Affected
2.0.98.1 and older
Fixed in
2.0.99 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Quads Ads Manager for Google AdSense plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 2.0.98.1 due to insufficient input sanitization and output escaping of multiple ad metadata parameters. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-2595Wordfence advisoryCode change (fix)

critical 9.3 CVE-2025-30876 · published 2025-04-01

SQL injection in Quads Ads Manager for Google AdSense (2.0.87.1 and older)

Affected
2.0.87.1 and older
Fixed in
2.0.88
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Ads by WPQuads Ads by WPQuads quick-adsense-reloaded allows SQL Injection.This issue affects Ads by WPQuads: from n/a through <= 2.0.87.1.

NVD CVE-2025-30876Patchstack advisory

high 7.5 CVE-2025-30855 · published 2025-03-31

Missing authorization check in Quads Ads Manager for Google AdSense (2.0.87.1 and older)

Affected
2.0.87.1 and older
Fixed in
2.0.88
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Ads by WPQuads Ads by WPQuads quick-adsense-reloaded allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Ads by WPQuads: from n/a through <= 2.0.87.1.

NVD CVE-2025-30855Patchstack advisory

high 8.8 CVE-2024-47317 · published 2024-11-01

Missing authorization check in Quads Ads Manager for Google AdSense (2.0.84 and older)

Affected
2.0.84 and older
Fixed in
2.0.85
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Missing Authorization vulnerability in Ads by WPQuads Ads by WPQuads quick-adsense-reloaded.This issue affects Ads by WPQuads: from n/a through <= 2.0.84.

NVD CVE-2024-47317Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Quads Ads Manager for Google AdSense vulnerability status badge
<a href="https://laskyr.com/plugins/quick-adsense-reloaded"><img src="https://laskyr.com/plugins/quick-adsense-reloaded/badge.svg" alt="Quads Ads Manager for Google AdSense vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit