Plugins · question-answer · data as of 2026-11-04
Is PickPlugins Question Answer safe? Known vulnerabilities and latest version
- Status
- Closed 2026-07-27
- Known issues on record
- 4
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate question-answer && wp plugin delete question-answer
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 4 record(s) do not state which versions are affected.
high 7.5 CVE-2026-10207 · published 2026-07-28
SQL injection in PickPlugins Question Answer (1.2.73 and older)
- Affected
- 1.2.73 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The PickPlugins Question Answer plugin for WordPress is vulnerable to SQL Injection in versions up to and including 1.2.73. This is due to insufficient sanitization of user-supplied input via the 'id' GET parameter in the user profile template combined with the use of wp_unslash() which removes WordPress's magic quotes protection, followed by direct concatenation into a SQL query without proper escaping or prepared statements in the qa_user_profile_card() function. This makes it possible for unauthenticated attackers to append additional SQL queries into existing queries, which can be used to extract sensitive information from the database.
high 7.1 CVE-2025-32646 · published 2025-04-17
Reflected cross-site scripting (XSS) in PickPlugins Question Answer (1.2.70 and older)
- Affected
- 1.2.70 and older
- Fixed in
- 1.2.71
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in PickPlugins Question Answer question-answer allows Reflected XSS.This issue affects Question Answer: from n/a through <= 1.2.70.
high 8.8 CVE-2025-32647 · published 2025-04-17
PHP object injection in PickPlugins Question Answer (1.2.73 and older)
- Affected
- 1.2.73 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Deserialization of Untrusted Data vulnerability in PickPlugins Question Answer question-answer allows Object Injection.This issue affects Question Answer: from n/a through <= 1.2.73.
medium 5.3 CVE-2025-31810 · published 2025-04-01
Missing authorization check in PickPlugins Question Answer (1.2.73 and older)
- Affected
- 1.2.73 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in PickPlugins Question Answer question-answer allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects Question Answer: from n/a through <= 1.2.73.
Recent activity
- 2026-07-27 — closed on wordpress.org (Security Issue).
- 2026-07-28 — SQL injection disclosed (CVE-2026-10207), fix version not stated.
- 2025-04-17 — Reflected cross-site scripting (XSS) disclosed (CVE-2025-32646), fixed in 1.2.71.
- 2025-04-17 — PHP object injection disclosed (CVE-2025-32647), fix version not stated.
Get an email when PickPlugins Question Answer has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for PickPlugins Question Answer (question-answer) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: SQL injection (1) · Cross-site scripting (XSS) (1) · PHP object injection (1) · Missing authorization (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/question-answer (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/question-answer"><img src="https://laskyr.com/plugins/question-answer/badge.svg" alt="PickPlugins Question Answer vulnerability status"></a>