Skip to content
Laskyr

Plugins · query-monitor · data as of 2026-11-04

Is Query Monitor safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.1.1)

As of 2026-11-04. 1 issue is on record for older versions; version 3.20.4 or newer fixes all of them that state a fix.

Latest version
4.1.1
Last updated
2026-10-27
Active installs
200,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Query Monitor is the developer tools panel for WordPress and WooCommerce. — by John Blackbourn

What to do

  1. Update to the latest version (4.1.1). Anything older than 3.20.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get query-monitor --field=version shows what you run; wp plugin update query-monitor updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-4267 · published 2026-03-31

Reflected cross-site scripting (XSS) in Query Monitor (3.20.3 and older)

Affected
3.20.3 and older
Fixed in
3.20.4 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Query Monitor – The developer tools panel for WordPress plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘$_SERVER['REQUEST_URI']’ parameter in all versions up to, and including, 3.20.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2026-4267Wordfence advisoryCode change (fix)research.cleantalk.orgPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Query Monitor vulnerability status badge
<a href="https://laskyr.com/plugins/query-monitor"><img src="https://laskyr.com/plugins/query-monitor/badge.svg" alt="Query Monitor vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit