Plugins · pz-linkcard · data as of 2026-11-04
Is Pz-LinkCard safe? Known vulnerabilities and latest version
- Latest version
- 2.6.4
- Last updated
- 2026-10-24
- Active installs
- 20,000+
- Known issues on record
- 7
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.2+
このプラグインはリンクをカード形式で表示します。テキストだけのリンクにさようなら! This plugin is intended to display a link in a blog card format. The goodbye to the text-only link. — by ぽぽろん@ぽぽづれ。
What to do
- Update to the latest version (2.6.4). Anything older than 2.5.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get pz-linkcard --field=version shows what you run; wp plugin update pz-linkcard updates it.
Check your version
Known vulnerabilities
7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-2434 · published 2026-04-17
Stored cross-site scripting (XSS) in Pz-LinkCard (2.5.8.1 and older)
- Affected
- 2.5.8.1 and older
- Fixed in
- 2.5.9 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Pz-LinkCard plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'blogcard' shortcode attributes in all versions up to, and including, 2.5.8.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
low 3.8 CVE-2025-8594 · published 2025-10-14
Server-side request forgery (SSRF) in Pz-LinkCard (older than 2.5.7)
- Affected
- older than 2.5.7
- Fixed in
- 2.5.7
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Pz-LinkCard WordPress plugin before 2.5.7 does not validate a parameter before making a request to it, which could allow users with a role as low as Contributor to perform SSRF attack.
high 7.1 CVE-2024-0672 · published 2024-03-28
Reflected cross-site scripting (XSS) in Pz-LinkCard (2.5.1 and older)
- Affected
- 2.5.1 and older
- Fixed in
- 2.5.2 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Pz-LinkCard WordPress plugin through 2.5.1 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
medium 6.1 CVE-2024-0673 · published 2024-03-28
Cross-site scripting (XSS) in Pz-LinkCard (2.5.1 and older)
- Affected
- 2.5.1 and older
- Fixed in
- 2.5.2 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Pz-LinkCard WordPress plugin through 2.5.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed
medium 5.1 CVE-2024-0677 · published 2024-03-28
Server-side request forgery (SSRF) in Pz-LinkCard (2.5.1 and older)
- Affected
- 2.5.1 and older
- Fixed in
- 2.5.2 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The Pz-LinkCard WordPress plugin through 2.5.1 does not prevent users from pinging arbitrary hosts via some of its shortcodes, which could allow high privilege users such as contributors to perform SSRF attacks.
medium 6.1 CVE-2023-47790 · published 2023-11-23
Cross-site request forgery (CSRF) in Pz-LinkCard (2.4.8 and older)
- Affected
- 2.4.8 and older
- Fixed in
- 2.4.8.1 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) leading to Cross-Site Scripting (XSS) vulnerability in Poporon Pz-LinkCard plugin <= 2.4.8 versions.
medium 6.1 CVE-2021-25012 · published 2022-03-28
Reflected cross-site scripting (XSS) in Pz-LinkCard (2.4.4.4 to 2.4.4.4)
- Affected
- 2.4.4.4 to 2.4.4.4
- Fixed in
- 2.4.5 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Pz-LinkCard WordPress plugin through 2.4.4.4 does not sanitise and escape multiple parameters before outputting them back in admin dashboard pages, leading to Reflected Cross-Site Scripting issues
Recent activity
- 2026-10-24 — latest release on wordpress.org (2.6.4).
- 2026-04-17 — Stored cross-site scripting (XSS) disclosed (CVE-2026-2434), fixed in 2.5.9.
- 2025-10-14 — Server-side request forgery (SSRF) disclosed (CVE-2025-8594), fixed in 2.5.7.
- 2024-03-28 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-0672), fixed in 2.5.2.
Get an email when Pz-LinkCard has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Pz-LinkCard (pz-linkcard) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (4) · Server-side request forgery (SSRF) (2) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/pz-linkcard (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/pz-linkcard"><img src="https://laskyr.com/plugins/pz-linkcard/badge.svg" alt="Pz-LinkCard vulnerability status"></a>