Plugins · pz-frontend-manager · data as of 2026-11-04
Is PZ Frontend Manager safe? Known vulnerabilities and latest version
- Status
- Closed 2026-03-20
- Known issues on record
- 2
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate pz-frontend-manager && wp plugin delete pz-frontend-manager
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 2 record(s) do not state which versions are affected.
medium 5.3 CVE-2026-3477 · published 2026-04-08
Missing authorization check in PZ Frontend Manager (1.0.6 and older)
- Affected
- 1.0.6 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The PZ Frontend Manager plugin for WordPress is vulnerable to Missing Authorization in all versions up to and including 1.0.6. The pzfm_user_request_action_callback() function, registered via the wp_ajax_pzfm_user_request_action action hook, lacks both capability checks and nonce verification. This function handles user activation, deactivation, and deletion operations. When the 'dataType' parameter is set to 'delete', the function calls wp_delete_user() on all provided user IDs without verifying that the current user has the appropriate permissions. Notably, the similar pzfm_remove_item_callback() function does check pzfm_can_delete_user() before performing deletions, indicating this was an oversight. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete arbitrary WordPress users (including administrators) by sending a crafted request to the AJAX endpoint.
high 8.8 CVE-2024-6244 · published 2024-07-22
Cross-site request forgery (CSRF) in PZ Frontend Manager (older than 1.0.6)
- Affected
- older than 1.0.6
- Fixed in
- 1.0.6
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The PZ Frontend Manager WordPress plugin before 1.0.6 does not have CSRF checks in some places, which could allow attackers to make logged in users perform unwanted actions via CSRF attacks
Recent activity
- 2026-03-20 — closed on wordpress.org (Security Issue).
- 2026-04-08 — Missing authorization check disclosed (CVE-2026-3477), fix version not stated.
- 2024-07-22 — Cross-site request forgery (CSRF) disclosed (CVE-2024-6244), fixed in 1.0.6.
Get an email when PZ Frontend Manager has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for PZ Frontend Manager (pz-frontend-manager) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/pz-frontend-manager (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/pz-frontend-manager"><img src="https://laskyr.com/plugins/pz-frontend-manager/badge.svg" alt="PZ Frontend Manager vulnerability status"></a>