Skip to content
Laskyr

Plugins · pymntpl-paypal-woocommerce · data as of 2026-11-04

Is Payment Plugins for PayPal WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0.29)

As of 2026-11-04. 5 issues are on record for older versions; version 2.0.27 or newer fixes all of them that state a fix.

Latest version
2.0.29
Last updated
2026-10-27
Active installs
80,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Developed exclusively between Payment Plugins and PayPal, PayPal for WooCommerce integrates with PayPal's newest API's. — by Payment Plugins

What to do

  1. Update to the latest version (2.0.29). Anything older than 2.0.27 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get pymntpl-paypal-woocommerce --field=version shows what you run; wp plugin update pymntpl-paypal-woocommerce updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-80342 · published 2026-09-23

Missing authorization check in Payment Plugins for PayPal WooCommerce (older than 2.0.27)

Affected
older than 2.0.27
Fixed in
2.0.27
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Payment Plugins for PayPal WooCommerce WordPress plugin before 2.0.27 does not verify that a PayPal order supplied in a payment request belongs to the WooCommerce order being paid unless that PayPal order has already been completed, allowing unauthenticated attackers to have another buyer's approved but uncaptured payment captured against an order of their own.

NVD CVE-2026-80342WPScan advisory

medium 5.3 CVE-2026-80340 · published 2026-09-09

Information disclosure in Payment Plugins for PayPal WooCommerce (1.0.0 up to (not including) 2.0.26)

Affected
1.0.0 up to (not including) 2.0.26
Fixed in
2.0.26
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Payment Plugins for PayPal WooCommerce WordPress plugin before 2.0.26 does not validate the order key before adding order data to the JavaScript configuration it outputs on the front end, allowing unauthenticated users to obtain the secret that gates access to any order and, through it, that customer's billing and shipping details, by iterating sequential order identifiers.

NVD CVE-2026-80340WPScan advisory

medium 5.9 CVE-2026-80341 · published 2026-09-09

Missing authorization check in Payment Plugins for PayPal WooCommerce (1.1.0 up to (not including) 2.0.26)

Affected
1.1.0 up to (not including) 2.0.26
Fixed in
2.0.26
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Payment Plugins for PayPal WooCommerce WordPress plugin before 2.0.26 does not verify that a stored payment method belongs to the user attaching it, allowing any authenticated user, such as a subscriber, to bind another customer's stored card to their own account and then charge or delete it. Exploitation requires the attacker to already know the payment provider's identifier for the victim's stored method, which the Payment Plugins for PayPal WooCommerce WordPress plugin before 2.0.26 does not expose.

NVD CVE-2026-80341WPScan advisory

high 7.5 CVE-2026-13399 · published 2026-08-06

Missing authorization check in Payment Plugins for PayPal WooCommerce (older than 2.0.20)

Affected
older than 2.0.20
Fixed in
2.0.20
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by WPScan
Details from the advisory

The Payment Plugins for PayPal WooCommerce WordPress plugin before 2.0.20 does not have proper authorization checks on a REST endpoint, allowing unauthenticated users to bypass payments

NVD CVE-2026-13399WPScan advisory

medium 5.3 CVE-2026-39643 · published 2026-04-08

Missing authorization check in Payment Plugins for PayPal WooCommerce (2.0.13 and older)

Affected
2.0.13 and older
Fixed in
2.0.14 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Payment Plugins Payment Plugins for PayPal WooCommerce pymntpl-paypal-woocommerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Payment Plugins for PayPal WooCommerce: from n/a through <= 2.0.13.

NVD CVE-2026-39643Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Payment Plugins for PayPal WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/pymntpl-paypal-woocommerce"><img src="https://laskyr.com/plugins/pymntpl-paypal-woocommerce/badge.svg" alt="Payment Plugins for PayPal WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit