Plugins · pushengage · data as of 2026-11-04
Is PushEngage safe? Known vulnerabilities and latest version
- Latest version
- 4.2.11
- Last updated
- 2026-09-23
- Active installs
- 8,000+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Web push notifications, WooCommerce automation & multi-channel chat widget. WhatsApp cart recovery, browser alerts — one plugin. — by Syed Balkhi
What to do
- Update to the latest version (4.2.11). Anything older than 4.2.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get pushengage --field=version shows what you run; wp plugin update pushengage updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.4 CVE-2026-52698 · published 2026-06-17
Information disclosure in PushEngage (4.2.3 and older)
- Affected
- 4.2.3 and older
- Fixed in
- 4.2.4
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Subscriber Sensitive Data Exposure in PushEngage – Web Push Notifications, eCommerce Automation & Chat Widget <= 4.2.3 versions.
Recent activity
- 2026-09-23 — latest release on wordpress.org (4.2.11).
- 2026-06-17 — Information disclosure disclosed (CVE-2026-52698), fixed in 4.2.4.
Get an email when PushEngage has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for PushEngage (pushengage) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Syed Balkhi (28 tracked)
Types found in this plugin: Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/pushengage (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/pushengage"><img src="https://laskyr.com/plugins/pushengage/badge.svg" alt="PushEngage vulnerability status"></a>