Skip to content
Laskyr

Plugins · push-notification-for-post-and-buddypress · data as of 2026-11-04

Is Push Notification for Post and BuddyPress safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.24)

As of 2026-11-04. 5 issues are on record for older versions; version 3.24 or newer fixes all of them that state a fix.

Latest version
3.24
Last updated
2026-10-09
Active installs
200+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.1+

Push notifications for WordPress post, BuddyPress, WooCommerce with PWA support, mobile app integration, and AI Notification drafts. — by Murali

What to do

  1. Update to the latest version (3.24). Anything older than 3.24 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get push-notification-for-post-and-buddypress --field=version shows what you run; wp plugin update push-notification-for-post-and-buddypress updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-107417 · published 2026-10-14

Missing authorization check in Push Notification for Post and BuddyPress (3.23 and older)

Affected
3.23 and older
Fixed in
3.24
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Muralidharan Ramasamy Push Notification for Post and BuddyPress push-notification-for-post-and-buddypress allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Push Notification for Post and BuddyPress: from n/a through 3.23.

NVD CVE-2026-107417Patchstack advisory

medium 5.4 CVE-2026-81279 · published 2026-08-27

Missing authorization check in Push Notification for Post and BuddyPress (3.20 and older)

Affected
3.20 and older
Fixed in
3.21
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Broken Access Control in Push Notification for Post and BuddyPress <= 3.20 versions.

NVD CVE-2026-81279Patchstack advisory

critical 9.8 CVE-2024-6159 · published 2025-05-15

SQL injection in Push Notification for Post and BuddyPress (older than 1.9.4)

Affected
older than 1.9.4
Fixed in
1.9.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Push Notification for Post and BuddyPress WordPress plugin before 1.9.4 does not properly sanitise and escape a parameter before using it in a SQL statement via an AJAX action available to unauthenticated users, leading to a SQL injection

NVD CVE-2024-6159WPScan advisory

medium 6.5 CVE-2025-23771 · published 2025-02-14

Missing authorization check in Push Notification for Post and BuddyPress (2.11 and older)

Affected
2.11 and older
Fixed in
2.12
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Murali Push Notification for Post and BuddyPress push-notification-for-post-and-buddypress allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Push Notification for Post and BuddyPress: from n/a through <= 2.11.

NVD CVE-2025-23771Patchstack advisory

medium 6.1 CVE-2024-12407 · published 2025-01-11

Reflected cross-site scripting (XSS) in Push Notification for Post and BuddyPress (2.06 and older)

Affected
2.06 and older
Fixed in
2.07 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Push Notification for Post and BuddyPress plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'pushnotificationid' parameter in all versions up to, and including, 2.07 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2024-12407Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Push Notification for Post and BuddyPress vulnerability status badge
<a href="https://laskyr.com/plugins/push-notification-for-post-and-buddypress"><img src="https://laskyr.com/plugins/push-notification-for-post-and-buddypress/badge.svg" alt="Push Notification for Post and BuddyPress vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit