Skip to content
Laskyr

Plugins · proxy-vpn-blocker · data as of 2026-11-04

Is Proxy & VPN Blocker safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.6.0)

As of 2026-11-04. 2 issues are on record for older versions; version 3.5.9 or newer fixes all of them that state a fix.

Latest version
3.6.0
Last updated
2026-08-20
Active installs
1,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

Block VPNs, proxies, Tor, and spam on WordPress. Strengthen security and stop fake users with smart IP blocking via proxycheck.io. — by Proxy & VPN Blocker

What to do

  1. Update to the latest version (3.6.0). Anything older than 3.5.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get proxy-vpn-blocker --field=version shows what you run; wp plugin update proxy-vpn-blocker updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-57399 · published 2026-07-13

Stored cross-site scripting (XSS) in Proxy & VPN Blocker (3.5.8 and older)

Affected
3.5.8 and older
Fixed in
3.5.9
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Proxy &amp; VPN Blocker Proxy &amp; VPN Blocker proxy-vpn-blocker allows Stored XSS.This issue affects Proxy &amp; VPN Blocker: from n/a through <= 3.5.8.

NVD CVE-2026-57399Patchstack advisory

medium 4.3 CVE-2025-69353 · published 2026-01-06

Missing authorization check in Proxy & VPN Blocker (3.5.3 and older)

Affected
3.5.3 and older
Fixed in
3.5.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Proxy & VPN Blocker Proxy & VPN Blocker proxy-vpn-blocker allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Proxy & VPN Blocker: from n/a through <= 3.5.3.

NVD CVE-2025-69353Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Proxy & VPN Blocker vulnerability status badge
<a href="https://laskyr.com/plugins/proxy-vpn-blocker"><img src="https://laskyr.com/plugins/proxy-vpn-blocker/badge.svg" alt="Proxy & VPN Blocker vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit