Skip to content
Laskyr

Plugins · protect-wp-admin · data as of 2026-11-04

Is Protect WP Admin safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.2)

As of 2026-11-04. 3 issues are on record for older versions; version 4.2 or newer fixes all of them that state a fix.

Latest version
4.2
Last updated
2026-02-05
Active installs
10,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
6.9.11

Protect your WP site by changing the default wp-admin URL and customizing the login page for enhanced security. — by WP-EXPERTS.IN

What to do

  1. Update to the latest version (4.2). Anything older than 4.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get protect-wp-admin --field=version shows what you run; wp plugin update protect-wp-admin updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2025-64249 · published 2025-12-16

Missing authorization check in Protect WP Admin (4.1 and older)

Affected
4.1 and older
Fixed in
4.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WP-EXPERTS.IN Protect WP Admin protect-wp-admin allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Protect WP Admin: from n/a through <= 4.1.

NVD CVE-2025-64249Patchstack advisory

medium 6.1 CVE-2023-3139 · published 2023-07-04

Open redirect in Protect WP Admin (older than 4.0)

Affected
older than 4.0
Fixed in
4.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Protect WP Admin WordPress plugin before 4.0 discloses the URL of the admin panel via a redirection of a crafted URL, bypassing the protection offered.

NVD CVE-2023-3139WPScan advisorymagos-securitas.com

high 7.5 CVE-2021-24906 · published 2022-01-24

Missing authorization check in Protect WP Admin (older than 3.6.2)

Affected
older than 3.6.2
Fixed in
3.6.2
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

The Protect WP Admin WordPress plugin before 3.6.2 does not check for authorisation in the lib/pwa-deactivate.php file, which could allow unauthenticated users to disable the plugin (and therefore the protection offered) via a crafted request

NVD CVE-2021-24906WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Protect WP Admin vulnerability status badge
<a href="https://laskyr.com/plugins/protect-wp-admin"><img src="https://laskyr.com/plugins/protect-wp-admin/badge.svg" alt="Protect WP Admin vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit