Skip to content
Laskyr

Plugins · pronamic-ideal · data as of 2026-11-04

Is Pronamic Pay safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (11.1.0)

As of 2026-11-04. 1 issue is on record for older versions; version 10.2.0 or newer fixes all of them that state a fix.

Latest version
11.1.0
Last updated
2026-11-02
Active installs
2,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.3+

The Pronamic Pay plugin adds payment methods like iDEAL | Wero, Bancontact, credit card and more to your WordPress site for a variety of payment provi … — by Pronamic

What to do

  1. Update to the latest version (11.1.0). Anything older than 10.2.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get pronamic-ideal --field=version shows what you run; wp plugin update pronamic-ideal updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.8 CVE-2026-16635 · published 2026-08-01

Privilege escalation in Pronamic Pay (10.1.0 and older)

Affected
10.1.0 and older
Fixed in
10.2.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Pronamic Pay plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 10.1.0 This is due to the `maybe_update_user_role()` function passing an attacker-controlled Gravity Forms field value (`$lead[$feed->user_role_field_id]`) directly into `WP_User::set_role()` without any allowlist validation, capability comparison, or permission check to constrain which roles can be assigned. This makes it possible for authenticated attackers, with Subscriber-level access and above, to escalate their own WordPress account to Administrator by tampering with the role field value in a form submission. Exploitation requires that an administrator has already configured a Pronamic Pay payment feed in Gravity Forms with the **Update User Role** option enabled and mapped to a form field; once that configuration is in place, no further preconditions exist to prevent an authenticated attacker from exploiting this vulnerability.

NVD CVE-2026-16635Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Pronamic Pay vulnerability status badge
<a href="https://laskyr.com/plugins/pronamic-ideal"><img src="https://laskyr.com/plugins/pronamic-ideal/badge.svg" alt="Pronamic Pay vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit