Plugins · progress-planner · data as of 2026-11-04
Is Progress Planner safe? Known vulnerabilities and latest version
- Status
- Closed 2026-10-26
- Known issues on record
- 5
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate progress-planner && wp plugin delete progress-planner
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 5 record(s) do not state which versions are affected.
high 8.8 CVE-2026-62072 · published 2026-10-06
Missing authorization check in Progress Planner (1.10.0 and older)
- Affected
- 1.10.0 and older
- Fixed in
- 1.10.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Subscriber Broken Access Control in Progress Planner <= 1.10.0 versions.
medium 5.9 CVE-2026-28116 · published 2026-06-02
Stored cross-site scripting (XSS) in Progress Planner (1.9.0 and older)
- Affected
- 1.9.0 and older
- Fixed in
- 1.9.1
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Emilia Projects Progress Planner allows Stored XSS. This issue affects Progress Planner: from n/a through 1.9.0.
high 8.8 CVE-2025-48082 · published 2025-10-22
Privilege escalation in Progress Planner (1.8.0 and older)
- Affected
- 1.8.0 and older
- Fixed in
- 1.8.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Incorrect Privilege Assignment vulnerability in Progress Planner Progress Planner progress-planner allows Privilege Escalation.This issue affects Progress Planner: from n/a through <= 1.8.0.
medium 5.3 CVE-2024-37411 · published 2024-11-01
Missing authorization check in Progress Planner (0.9.1 and older)
- Affected
- 0.9.1 and older
- Fixed in
- 0.9.2
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Progress Planner Progress Planner progress-planner.This issue affects Progress Planner: from n/a through <= 0.9.1.
medium 5.4 CVE-2024-37422 · published 2024-07-22
Cross-site scripting (XSS) in Progress Planner (0.9.2 and older)
- Affected
- 0.9.2 and older
- Fixed in
- 0.9.3
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Progress Planner Progress Planner progress-planner.This issue affects Progress Planner: from n/a through <= 0.9.2.
Recent activity
- 2026-10-26 — closed on wordpress.org (Author Request).
- 2026-10-06 — Missing authorization check disclosed (CVE-2026-62072), fixed in 1.10.1.
- 2026-06-02 — Stored cross-site scripting (XSS) disclosed (CVE-2026-28116), fixed in 1.9.1.
- 2025-10-22 — Privilege escalation disclosed (CVE-2025-48082), fixed in 1.8.1.
Get an email when Progress Planner has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Progress Planner (progress-planner) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (2) · Cross-site scripting (XSS) (2) · Privilege escalation (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/progress-planner (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/progress-planner"><img src="https://laskyr.com/plugins/progress-planner/badge.svg" alt="Progress Planner vulnerability status"></a>