Skip to content
Laskyr

Plugins · product-video-gallery-slider-for-woocommerce · data as of 2026-11-04

Is Product Video Gallery for Woocommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.5.2.4)

As of 2026-11-04. 1 issue is on record for older versions; version 1.5.1.9 or newer fixes all of them that state a fix.

Latest version
1.5.2.4
Last updated
2026-10-30
Active installs
10,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Product Video Gallery for Woocommerce – Embed videos to product gallery along with images on product single page of WooCommerce. — by NikHiL Gadhiya

What to do

  1. Update to the latest version (1.5.2.4). Anything older than 1.5.1.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get product-video-gallery-slider-for-woocommerce --field=version shows what you run; wp plugin update product-video-gallery-slider-for-woocommerce updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.4 CVE-2026-10104 · published 2026-07-02

Stored cross-site scripting (XSS) in Product Video Gallery for Woocommerce (1.5.1.8 and older)

Affected
1.5.1.8 and older
Fixed in
1.5.1.9 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Product Video Gallery for Woocommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via custom_thumbnail Parameter in all versions up to, and including, 1.5.1.8 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with shop manager-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-10104Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Product Video Gallery for Woocommerce vulnerability status badge
<a href="https://laskyr.com/plugins/product-video-gallery-slider-for-woocommerce"><img src="https://laskyr.com/plugins/product-video-gallery-slider-for-woocommerce/badge.svg" alt="Product Video Gallery for Woocommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit