Skip to content
Laskyr

Plugins · product-specifications · data as of 2026-11-04

Is Product Specifications for Woocommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (0.8.10)

As of 2026-11-04. 2 issues are on record for older versions; version 0.8.10 or newer fixes all of them that state a fix.

Latest version
0.8.10
Last updated
2026-06-20
Active installs
1,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

This plugin adds a product specifications table to your woocommerce single-product page. — by Dornaweb

What to do

  1. Update to the latest version (0.8.10). Anything older than 0.8.10 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get product-specifications --field=version shows what you run; wp plugin update product-specifications updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-11364 · published 2026-06-27

Missing authorization check in Product Specifications for Woocommerce (0.8.9 and older)

Affected
0.8.9 and older
Fixed in
0.8.10 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Product Specifications for WooCommerce plugin for WordPress is vulnerable to unauthorized modification, creation, and deletion of data in versions up to and including 0.8.9. This is due to a missing capability check and missing nonce verification in the __invoke() methods of the AttributeGroupController and AttributeController classes, which are bound to the 'dwps_modify_groups' and 'dwps_modify_attributes' AJAX actions. This makes it possible for authenticated attackers, with Subscriber-level access and above, to create, edit, and delete arbitrary product specification groups and attributes (taxonomy terms in the 'spec-group' and attribute taxonomies), corrupting business data and impacting the site's frontend display.

NVD CVE-2026-11364Wordfence advisoryCode change (fix)Plugin source

medium 6.1 CVE-2022-46858 · published 2023-05-09

Reflected cross-site scripting (XSS) in Product Specifications for Woocommerce (0.6.0 and older)

Affected
0.6.0 and older
Fixed in
0.7.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Amin A.Rezapour Product Specifications for Woocommerce plugin <= 0.6.0 versions.

NVD CVE-2022-46858Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Product Specifications for Woocommerce vulnerability status badge
<a href="https://laskyr.com/plugins/product-specifications"><img src="https://laskyr.com/plugins/product-specifications/badge.svg" alt="Product Specifications for Woocommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit