Skip to content
Laskyr

Plugins · product-import-export-for-woo · data as of 2026-11-04

Is Product Import Export for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.6.8)

As of 2026-11-04. 7 issues are on record for older versions; version 2.5.7 or newer fixes all of them that state a fix.

Latest version
2.6.8
Last updated
2026-10-26
Active installs
80,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

Import and export WooCommerce products via CSV. Bulk upload products, update stock and prices, and import or export product images. — by WebToffee

What to do

  1. Update to the latest version (2.6.8). Anything older than 2.5.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get product-import-export-for-woo --field=version shows what you run; wp plugin update product-import-export-for-woo updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-48971 · published 2026-05-27

Missing authorization check in Product Import Export for WooCommerce (2.5.6 and older)

Affected
2.5.6 and older
Fixed in
2.5.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in WebToffee Product Import Export for WooCommerce allows Exploiting Incorrectly Configured Access Control Security Levels. This issue affects Product Import Export for WooCommerce: from n/a through 2.5.6.

NVD CVE-2026-48971Patchstack advisory

medium 4.9 CVE-2025-1769 · published 2025-03-26

Path traversal / file read in Product Import Export for WooCommerce (2.5.0 and older)

Affected
2.5.0 and older
Fixed in
2.5.1 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Product Import Export for WooCommerce – Import Export Product CSV Suite plugin for WordPress is vulnerable to Directory Traversal in all versions up to, and including, 2.5.0 via the download_file() function. This makes it possible for authenticated attackers, with Administrator-level access and above, to read the contents of arbitrary log files on the server, which can contain sensitive information.

NVD CVE-2025-1769Wordfence advisoryCode change (fix)wordpress.orgPlugin source

medium 6.5 CVE-2025-1911 · published 2025-03-26

Arbitrary file deletion in Product Import Export for WooCommerce (2.5.0 and older)

Affected
2.5.0 and older
Fixed in
2.5.1 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Product Import Export for WooCommerce – Import Export Product CSV Suite plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the admin_log_page() function in all versions up to, and including, 2.5.0. This makes it possible for authenticated attackers, with Administrator-level access and above, to delete arbitrary log files on the server.

NVD CVE-2025-1911Wordfence advisoryCode change (fix)wordpress.orgPlugin source

high 7.6 CVE-2025-1912 · published 2025-03-26

Server-side request forgery (SSRF) in Product Import Export for WooCommerce (2.5.0 and older)

Affected
2.5.0 and older
Fixed in
2.5.1 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Product Import Export for WooCommerce – Import Export Product CSV Suite plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.5.0 via the validate_file() Function. This makes it possible for authenticated attackers, with Administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.

NVD CVE-2025-1912Wordfence advisoryCode change (fix)wordpress.orgPlugin source

high 7.2 CVE-2025-1913 · published 2025-03-26

PHP object injection in Product Import Export for WooCommerce (2.5.0 and older)

Affected
2.5.0 and older
Fixed in
2.5.1 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Product Import Export for WooCommerce – Import Export Product CSV Suite plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 2.5.0 via deserialization of untrusted input from the 'form_data' parameter This makes it possible for authenticated attackers, with Administrator-level access and above, to inject a PHP Object. No known POP chain is present in the vulnerable software, which means this vulnerability has no impact unless another plugin or theme containing a POP chain is installed on the site. If a POP chain is present via an additional plugin or theme installed on the target system, it may allow the attacker to perform actions like delete arbitrary files, retrieve sensitive data, or execute code depending on the POP chain present.

NVD CVE-2025-1913Wordfence advisoryCode change (fix)wordpress.orggithub.comPlugin source

high 7.2 CVE-2024-30231 · published 2024-03-26

Arbitrary file upload in Product Import Export for WooCommerce (2.4.1 and older)

Affected
2.4.1 and older
Fixed in
2.4.2
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unrestricted Upload of File with Dangerous Type vulnerability in WebToffee Product Import Export for WooCommerce.This issue affects Product Import Export for WooCommerce: from n/a through 2.4.1.

NVD CVE-2024-30231Patchstack advisory

high 7.2 CVE-2024-22152 · published 2024-01-24

Arbitrary file upload in Product Import Export for WooCommerce (2.3.7 and older)

Affected
2.3.7 and older
Fixed in
2.3.8
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unrestricted Upload of File with Dangerous Type vulnerability in WebToffee Product Import Export for WooCommerce.This issue affects Product Import Export for WooCommerce: from n/a through 2.3.7.

NVD CVE-2024-22152Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Product Import Export for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/product-import-export-for-woo"><img src="https://laskyr.com/plugins/product-import-export-for-woo/badge.svg" alt="Product Import Export for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit