Skip to content
Laskyr

Plugins · product-configurator-for-woocommerce · data as of 2026-11-04

Is MKL Product Configurator for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0.1)

As of 2026-11-04. 2 issues are on record for older versions; version 1.7.6 or newer fixes all of them that state a fix.

Latest version
2.0.1
Last updated
2026-10-31
Active installs
2,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Build 2D and 3D product configurators for WooCommerce. Customers design their product with a live visual preview, then add it to the cart. — by mklacroix

What to do

  1. Update to the latest version (2.0.1). Anything older than 1.7.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get product-configurator-for-woocommerce --field=version shows what you run; wp plugin update product-configurator-for-woocommerce updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-105872 · published 2026-10-09

PHP object injection in MKL Product Configurator for WooCommerce (1.7.5 and older)

Affected
1.7.5 and older
Fixed in
1.7.6
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in mklacroix Product Configurator for WooCommerce product-configurator-for-woocommerce allows Object Injection.This issue affects Product Configurator for WooCommerce: from n/a through 1.7.5.

NVD CVE-2026-105872Patchstack advisory

medium 5.4 CVE-2025-54674 · published 2025-08-14

Cross-site request forgery (CSRF) in MKL Product Configurator for WooCommerce (1.4.4 and older)

Affected
1.4.4 and older
Fixed in
1.5.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in mklacroix Product Configurator for WooCommerce product-configurator-for-woocommerce allows Cross Site Request Forgery.This issue affects Product Configurator for WooCommerce: from n/a through <= 1.4.4.

NVD CVE-2025-54674Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
MKL Product Configurator for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/product-configurator-for-woocommerce"><img src="https://laskyr.com/plugins/product-configurator-for-woocommerce/badge.svg" alt="MKL Product Configurator for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit