Skip to content
Laskyr

Plugins · product-catalog-feed · data as of 2026-11-04

Is Product Catalog Feed by PixelYourSite safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.2.0)

As of 2026-11-04. 4 issues are on record for older versions; version 2.2.0 or newer fixes all of them that state a fix.

Last updated on wordpress.org on 2023-10-15, more than two years ago. Plugins that stop getting updates also stop getting security fixes.

Latest version
2.2.0
Last updated
2023-10-15
Active installs
7,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
6.3.14

WooCommerce auto-updated XML feeds for Facebook Product Catalogs (Dynamic Product Ads, Facebook Shops, Instagram), Google Merchant, and Pinterest Cata … — by PixelYourSite

What to do

  1. Update to the latest version (2.2.0). Anything older than 2.2.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get product-catalog-feed --field=version shows what you run; wp plugin update product-catalog-feed updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 1 record(s) do not state which versions are affected.

high 7.2 CVE-2026-118078 · published 2026-10-29

PHP object injection in Product Catalog Feed by PixelYourSite (3.1.4 and older)

Affected
3.1.4 and older
Fixed in
unknown
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack

Note: the source's version range goes past the newest Product Catalog Feed by PixelYourSite release on wordpress.org (2.2.0), so it probably describes a paid edition with its own version numbers, or contains a typo. We do not use it to judge your version.

Details from the advisory

Shop manager PHP Object Injection in Product Catalog Feed by PixelYourSite <= 3.1.4 versions.

NVD CVE-2026-118078Patchstack advisory

high 8.8 CVE-2023-49824 · published 2023-12-17

Cross-site request forgery (CSRF) in Product Catalog Feed by PixelYourSite (2.1.1 and older)

Affected
2.1.1 and older
Fixed in
2.2.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in PixelYourSite Product Catalog Feed by PixelYourSite.This issue affects Product Catalog Feed by PixelYourSite: from n/a through 2.1.1.

NVD CVE-2023-49824Patchstack advisory

medium 6.1 CVE-2023-1804 · published 2023-05-02

Reflected cross-site scripting (XSS) in Product Catalog Feed by PixelYourSite (older than 2.1.1)

Affected
older than 2.1.1
Fixed in
2.1.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Product Catalog Feed by PixelYourSite WordPress plugin before 2.1.1 does not sanitise and escape the edit parameter before outputting it back in an attribute, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as administrators.

NVD CVE-2023-1804WPScan advisory

medium 6.1 CVE-2023-1805 · published 2023-05-02

Reflected cross-site scripting (XSS) in Product Catalog Feed by PixelYourSite (older than 2.1.1)

Affected
older than 2.1.1
Fixed in
2.1.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Product Catalog Feed by PixelYourSite WordPress plugin before 2.1.1 does not sanitise and escape the page parameter before outputting it back in an attribute, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin

NVD CVE-2023-1805WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Product Catalog Feed by PixelYourSite vulnerability status badge
<a href="https://laskyr.com/plugins/product-catalog-feed"><img src="https://laskyr.com/plugins/product-catalog-feed/badge.svg" alt="Product Catalog Feed by PixelYourSite vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit