Plugins · product-blocks · data as of 2026-11-04
Is WowStore safe? Known vulnerabilities and latest version
- Latest version
- 4.6.2
- Last updated
- 2026-11-02
- Active installs
- 4,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Build eCommerce sites & boost your earnings with the WooCommerce Builder, WooCommerce Blocks, and more effective features. — by WPXPO
What to do
- Update to the latest version (4.6.2). Anything older than 4.5.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get product-blocks --field=version shows what you run; wp plugin update product-blocks updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-17161 · published 2026-07-29
Stored cross-site scripting (XSS) in WowStore (4.4.24 and older)
- Affected
- 4.4.24 and older
- Fixed in
- 4.5.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WowStore – Store Builder & Product Blocks for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'filterMobileText' Block Attribute in all versions up to, and including, 4.4.24 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The save-time wp_kses_post sanitization is ineffective because the payload is stored inside a Gutenberg block delimiter comment as JSON, which wp_kses_post preserves, allowing an attribute-breakout string to survive to the server-side render_callback.
NVD CVE-2026-17161Wordfence advisoryCode change (fix)Plugin source
medium 6.4 CVE-2026-17162 · published 2026-07-29
Stored cross-site scripting (XSS) in WowStore (4.4.24 and older)
- Affected
- 4.4.24 and older
- Fixed in
- 4.5.0 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WowStore – Store Builder & Product Blocks for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'currentPostId' Block Attribute in all versions up to, and including, 4.4.24 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-17162Wordfence advisoryCode change (fix)Plugin source
high 7.5 CVE-2026-2579 · published 2026-03-17
SQL injection in WowStore (4.4.3 and older)
- Affected
- 4.4.3 and older
- Fixed in
- 4.4.4 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WowStore – Store Builder & Product Blocks for WooCommerce plugin for WordPress is vulnerable to SQL Injection via the ‘search’ parameter in all versions up to, and including, 4.4.3 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
medium 4.3 CVE-2025-39571 · published 2025-04-16
Missing authorization check in WowStore (4.2.4 and older)
- Affected
- 4.2.4 and older
- Fixed in
- 4.2.5
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in WPXPO WowStore product-blocks allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WowStore: from n/a through <= 4.2.4.
medium 4.3 CVE-2023-45271 · published 2025-01-02
Missing authorization check in WowStore (2.7.8 and older)
- Affected
- 2.7.8 and older
- Fixed in
- 3.0.0
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in WPXPO WowStore product-blocks allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WowStore: from n/a through <= 2.7.8.
critical 9.8 CVE-2024-23512 · published 2024-02-12
PHP object injection in WowStore (3.1.4 and older)
- Affected
- 3.1.4 and older
- Fixed in
- 3.1.5
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Deserialization of Untrusted Data vulnerability in wpxpo ProductX – WooCommerce Builder & Gutenberg WooCommerce Blocks.This issue affects ProductX – WooCommerce Builder & Gutenberg WooCommerce Blocks: from n/a through 3.1.4.
Recent activity
- 2026-11-02 — latest release on wordpress.org (4.6.2).
- 2026-07-29 — Stored cross-site scripting (XSS) disclosed (CVE-2026-17161), fixed in 4.5.0.
- 2026-07-29 — Stored cross-site scripting (XSS) disclosed (CVE-2026-17162), fixed in 4.5.0.
- 2026-03-17 — SQL injection disclosed (CVE-2026-2579), fixed in 4.4.4.
Get an email when WowStore has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WowStore (product-blocks) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by WPXPO (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · Missing authorization (2) · SQL injection (1) · PHP object injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/product-blocks (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/product-blocks"><img src="https://laskyr.com/plugins/product-blocks/badge.svg" alt="WowStore vulnerability status"></a>