Plugins · prodigy-commerce · data as of 2026-11-04
Is Prodigy Commerce safe? Known vulnerabilities and latest version
- Latest version
- 3.5.4
- Last updated
- 2026-10-26
- Active installs
- 20+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.0+
A powerful alternative to self-hosted eCommerce solutions. Combine WordPress with a full-featured, PCI-compliant platform. — by prodigycommerce
What to do
- Update to the latest version (3.5.4). Anything older than 3.3.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get prodigy-commerce --field=version shows what you run; wp plugin update prodigy-commerce updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
critical 9.8 CVE-2026-0926 · published 2026-02-19
File inclusion in Prodigy Commerce (3.3.0 and older)
- Affected
- 3.3.0 and older
- Fixed in
- 3.3.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Prodigy Commerce plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 3.3.0 via the 'parameters[template_name]' parameter. This makes it possible for unauthenticated attackers to include and read arbitrary files or execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included.
NVD CVE-2026-0926Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2024-54250 · published 2024-12-13
Cross-site scripting (XSS) in Prodigy Commerce (3.0.8 and older)
- Affected
- 3.0.8 and older
- Fixed in
- 3.0.9
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in prodigycommerce Prodigy Commerce prodigy-commerce allows DOM-Based XSS.This issue affects Prodigy Commerce: from n/a through <= 3.0.8.
medium 6.5 CVE-2024-54251 · published 2024-12-09
Missing authorization check in Prodigy Commerce (3.1.2 and older)
- Affected
- 3.1.2 and older
- Fixed in
- 3.1.3
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in prodigycommerce Prodigy Commerce prodigy-commerce allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Prodigy Commerce: from n/a through <= 3.1.2.
Recent activity
- 2026-10-26 — latest release on wordpress.org (3.5.4).
- 2026-02-19 — File inclusion disclosed (CVE-2026-0926), fixed in 3.3.1.
- 2024-12-13 — Cross-site scripting (XSS) disclosed (CVE-2024-54250), fixed in 3.0.9.
- 2024-12-09 — Missing authorization check disclosed (CVE-2024-54251), fixed in 3.1.3.
Get an email when Prodigy Commerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Prodigy Commerce (prodigy-commerce) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: File inclusion (1) · Cross-site scripting (XSS) (1) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/prodigy-commerce (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/prodigy-commerce"><img src="https://laskyr.com/plugins/prodigy-commerce/badge.svg" alt="Prodigy Commerce vulnerability status"></a>